Bug 110904 - libgcj depends on info package, but it is not listed as dependency
Summary: libgcj depends on info package, but it is not listed as dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 117394 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-25 14:19 UTC by Rik Faith
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 3.3.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 12:34:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:142 normal SHIPPED_LIVE GCC bugfix update 2004-05-11 04:00:00 UTC

Description Rik Faith 2003-11-25 14:19:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I'm installing a subset of Fedora Core packages for a chroot
environment.  I rely on RPM to check all the required dependencies.  I
see the following error:

  49:libgcj                
########################################### [ 36%]
/var/tmp/rpm-tmp.73696: line 3: /sbin/install-info: No such file or
directory
error: %post(libgcj-3.3.2-2) scriptlet failed, exit status 127


Version-Release number of selected component (if applicable):
libgcj-3.3.2-2

How reproducible:
Always

Steps to Reproduce:
1.Select a subset of RPMs, including libgcj, for installation.
2.Make the subset closed with respect to RPM dependencies.
3.Install all of the RPMs simultaneously.
    

Actual Results:  The post in libgcj fails to run because the
dependency on the info package isn't known to RPM.

Expected Results:  Successful %post.

Additional info:

Should there be a libgcj "component" for Fedora Core -- I found one
for RHL, but files this report under gcc because there wasn't one for
libgcj.

Comment 1 Miloslav Trmac 2003-11-25 15:42:39 UTC
Triage->Easyfix

Comment 2 Jakub Jelinek 2003-12-04 12:34:15 UTC
Should be fixed in gcc-3.3.2-3.

Comment 3 Jakub Jelinek 2004-03-03 15:56:29 UTC
*** Bug 117394 has been marked as a duplicate of this bug. ***

Comment 4 John Flanagan 2004-05-12 03:40:23 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-142.html



Note You need to log in before you can comment on or make changes to this bug.