Bug 110920 - cdparanoia progress broken
cdparanoia progress broken
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cdparanoia (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 10:53 EST by Michael Soulier
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-25 11:10:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Soulier 2003-11-25 10:53:33 EST
When I run cdparanoia -B, to rip all the tracks off of a song, the
output seems to have a newline in it instead of a carriage return. 

 (== PROGRESS == [>                             0| 000950 00 ] == :-)
0 ==) 
 (== PROGRESS == [>                             O| 000950 00 ] == :-)
O ==) 
 (== PROGRESS == [>                             0| 000952 00 ] == :-)
0 ==) 
 (== PROGRESS == [>                             o| 000952 00 ] == :-)
o ==) 
 (== PROGRESS == [>                             .| 000952 00 ] == :-)
. ==) 
 (== PROGRESS == [>                              | 000952 00 ] == :-)
  ==) 
 (== PROGRESS == [>                             .| 001095 00 ] == :-)
. ==) 
 (== PROGRESS == [>                             o| 001095 00 ] == :-)
o ==) 
 (== PROGRESS == [>                             0| 001095 00 ] == :-)
0 ==) 
 (== PROGRESS == [>                             O| 001096 00 ] == :-)
O ==) 
 (== PROGRESS == [>                             0| 001096 00 ] == :-)
0 ==) 
 (== PROGRESS == [>                             o| 001096 00 ] == :-)
o ==) 
 (== PROGRESS == [>                             .| 001099 00 ] == :-)
. ==) 
 (== PROGRESS == [>                              | 001099 00 ] == :-)
  ==) 
 (== PROGRESS == [>                             .| 001099 00 ] == :-)
. ==) 
 (== PROGRESS == [>                             o| 001099 00 ] == :-)
o ==) 

This is not what I should see. I should see one line, constantly
updating itself (achieved by outputting a carriage return and then
printing the line again). 

Looks like a bug in the output code.
Comment 1 Peter Jones 2003-11-25 11:10:05 EST
No, it's not that it's sending the wrong character.  The problem is
that cdparanoia expects for your terminal to be 80 columns wide, and
yours is not.  Unfortunately, rectifying this would be a fairly
invasive change with very little gain.  Feel free to submit a patch,
and I'll see if upstream will take it.

Note You need to log in before you can comment on or make changes to this bug.