Bug 110923 - ccm load-aplaws throws JAXRPCException
ccm load-aplaws throws JAXRPCException
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Daniel Berrange
:
Depends On: 109027 109900 110984
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 11:05 EST by Steve Etherington
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 10:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
verbose output from ccm load-aplaws (18.75 KB, text/plain)
2003-11-26 05:36 EST, Steve Etherington
no flags Details

  None (edit)
Description Steve Etherington 2003-11-25 11:05:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; BTO 
E1.07S; .NET CLR 1.1.4322)

Description of problem:
ccm load-aplaws loads lots of stuff into Oracle but eventual fails 
with a JAXRPCException. 

Version-Release number of selected component (if applicable):
6.1

How reproducible:
Didn't try

Steps to Reproduce:
1. ccm load-aplaws ...
2.
3.
    

Additional info:

I've just edited my project.xml to add ccm-cms (it already had ccm-
core). So don't know if that is the issue?

Here's the stack trace

2003-11-25 15:53:39,210 [ main] WARN  loader.CoreLoader - Done
com/arsdigita/content-section/ContentSection.pdl: line 115, column 37 
[warning]: table already has primary key: com/arsdigita/content-
section/ContentSection.pdl: line 41, column 38

Exception in thread "main" java.lang.NoClassDefFoundError: 
javax/xml/rpc/JAXRPCException
        at com.arsdigita.london.search.SearchUtils.setThreadCount
(SearchUtils.java:55)
        at com.arsdigita.london.search.Initializer.init
(Initializer.java:58)
        at com.arsdigita.runtime.CompoundInitializer.init
(CompoundInitializer.java:118)
        at com.arsdigita.runtime.Startup.run(Startup.java:205)
        at com.arsdigita.packaging.Loader.loadData(Loader.java:81)
        at com.arsdigita.packaging.Load.run(Load.java:287)
        at com.arsdigita.packaging.MasterTool.main
(MasterTool.java:100)
Comment 1 Daniel Berrange 2003-11-25 11:13:15 EST
Could you upload your project.xml and also provide the full command
line you are running 'ccm load-aplaws' with.

eg, something like:

  ccm load-aplaws --bundle /usr/share/ccm/aplaws-full.cfg --interactive
Comment 2 Steve Etherington 2003-11-25 11:16:39 EST
ccm load-aplaws --interactive --bundle /usr/share/ccm/aplaws-
full.txt --file /usr/share/ccm/aplaws.properties

<?xml version="1.0" encoding="ISO-8859-1"?>

<ccm:project name="aplaws-dev"
       prettyName="aplaws-dev"
       ccmVersion="6.1"
             type="application"


      xmlns:ccm="http://ccm.redhat.com/ccm-project">

  <!-- List all target databases here -->
  <ccm:databases>
    <ccm:database name="postgres"/>
    <ccm:database name="oracle-se"/>
  </ccm:databases>

  <!-- List all project specific applications here -->
  <ccm:build>
    <ccm:application name="aplaws-dev" prettyName="aplaws-dev" 
buildOrder="1"/>
  </ccm:build>

  <!-- List all shared, pre-built applications here -->
  <ccm:prebuilt>
    <ccm:application name="ccm-cms" version="6.1.0" buildOrder="1"/>
    <ccm:application name="ccm-core" version="6.1.0" buildOrder="1"/>
  </ccm:prebuilt>

</ccm:project>
Comment 3 Daniel Berrange 2003-11-25 14:05:28 EST
Your project.xml doesn't contain any of the APLAWS applications, so
you shouldn't be running 'ccm load-aplaws' using the 'aplaws-full.txt'
bundle, or the aplaws.properties file. Since you're only using Core &
CMS here, you should be running merely:

   ccm load --interactive ccm-core ccm-cms


What is wierd is that it is still picking up the classes for the
APLAWS search application, even though its not part of the project.xml.

To try and diagnose why this is happening can you also set:

  export CCM_TOOLS_VERBOSE=1

and then run the full 'ccm load-aplaws' command from your previous
comment. This will generate *alot* of output detailing stuff like the
class path. Please upload a file containing all of this output.
Comment 4 Steve Etherington 2003-11-26 05:36:39 EST
Created attachment 96207 [details]
verbose output from ccm load-aplaws

The command fails due to a DB problem, so we never get to the Exception. 

Is there a sql script to drop all the tables?

Also, it would probably be a good idea if the APLAWS installation doc were
expanded a bit to include when to run the load-aplaws option, and an example
project.xml
Comment 5 Daniel Berrange 2003-11-26 06:14:17 EST
Ok, the reason you fail on the DB step, is that you had already
created the schema on the previous run of 'ccm load-aplaws'.

The attachment you uploaded shows that too many irrelevant classes are
getting added to the CLASSPATH.

The script for dropping all tables is part of ccm-core-sql.jar which
is in /usr/share/java.

So in summary, you need to drop your current DB schema & then run 

  ccm load --interactive ccm-core ccm-cms

THis should get a system working with core & cms as per your project.xml
Comment 6 Steve Etherington 2003-11-28 05:23:36 EST
OK I solved this, but not quite in the way you said. Instead of 
changing the ccm load command, I added all the aplaws applications 
and types to project.xml. 

Some suggestions:

Say explicitly in the documentation that cms-types-* need to be added 
to the prebuilt applications section of the project.xml (It wasn't 
clear to me that they were definitely applications).

Add information to the documentaion on how to recover from a 
failed "ccm load". Alternatively, have "ccm load" drop the schema 
before loading it.

A general troubleshooting section on installation would be good.

Give complete installation instructions in the aplaws installation 
doc. At the moment this refers you to the WAF installation, and 
the "installing for development" section of that refers back to 
the "installing for production section", so I end up reading from 3 
sections simultaneously, and having to make additions and omissions 
here and there. It'd be better if it was all together in one place.

How about a command "ccm config --bundle /usr/share/ccm/aplaws-
full.txt" that would write my project.xml file for me (and maybe 
generate the build.xml too...)? In fact, "ccm config-load-aplaws ... 
etc" could gnerate project.xml, build.xml, ant deploy and load 
everything up...
Comment 7 Daniel Berrange 2004-01-28 10:12:45 EST
Closing since we've added alot more error checking and robustness to
the ccm load tools which should prevent the error conditions described
here from recurring.
Comment 8 Daniel Berrange 2004-01-28 10:13:05 EST
Actually closing it this time!

Note You need to log in before you can comment on or make changes to this bug.