Bug 110929 - certain __init__ files claimed by multiple subpackages
certain __init__ files claimed by multiple subpackages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-python2 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
: 111125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 11:33 EST by David Mansfield
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-25 12:11:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2003-11-25 11:33:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
After installing, multiple packages claim ownership of files in the
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/ directory.  For example:

[root@green root]# rpm -qf \
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyo
gnome-python2-canvas-1.99.14-5
gnome-python2-1.99.14-5

Additionally, if I rebuild the SRPM for the package, three more of the
subpackages attempt to install this (and the .pyc) file, and therefore
cannot be cleanly installed.

The changelog for 1.99.11 mentions fixing this (viewed via
rpmfind.net) but it is broken.


Version-Release number of selected component (if applicable):
gnome-python2-1.99.14-5

How reproducible:
Always

Steps to Reproduce:
1.install rhel3/es
2.
3.
    

Actual Results:  as above.

Expected Results:  files should be owned by 1 package only

Additional info:
Comment 1 Matt Wilson 2003-11-25 12:11:26 EST
you simply must install/upgrade all the packages which share the file
at the same time.  Subpackages owning that file is not a mistake. 
Various python modules can operate properly without the base gnome
python binding installed (such as the canvas binding).  Allowing the
subpackages to share the file breaks an unneeded dependency.
Comment 2 David Mansfield 2003-11-25 12:18:13 EST
But I cannot install the additional subpackages:

I realize you didn't ship these with rhel3/es, but it is a problem
with the packaging.  If you don't install the subpackage at install
time, you can never install it.

[root@green]# rpm -ivh gnome-python2-nautilus-1.99.14-5.i386.rpm 
Preparing...               
########################################### [100%]
        file
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyc from
install of gnome-python2-nautilus-1.99.14-5 conflicts with file from
package gnome-python2-canvas-1.99.14-5
        file
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyo from
install of gnome-python2-nautilus-1.99.14-5 conflicts with file from
package gnome-python2-canvas-1.99.14-5
        file
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyc from
install of gnome-python2-nautilus-1.99.14-5 conflicts with file from
package gnome-python2-1.99.14-5
        file
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyo from
install of gnome-python2-nautilus-1.99.14-5 conflicts with file from
package gnome-python2-1.99.14-5
Comment 3 Matt Wilson 2003-11-25 12:54:17 EST
you must install the packages you built instead of the packages that
shipped in RHEL 3.  This is the only way to make the .pyc and .pyo
files match.  Use "rpm -Uvh --replacepkgs" to overwrite the packages
that shipped with RHEL 3 or increase the release number when you rebuild.
Comment 4 Matt Wilson 2003-11-27 18:15:04 EST
*** Bug 111125 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.