This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 110958 - interactive configuration macros for rpm spec file
interactive configuration macros for rpm spec file
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 17:06 EST by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-30 10:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2003-11-25 17:06:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
How hard would it be to provide a set of macros to make it easier to
develop interactive configuration routines in the %post, %pre, etc.
sections of rpm installs?

I am thinking of a set of macros that test if rpm is being run
interactively and if a GUI is available.  There could also be timed
tests to see if the user wants to deal at that moment (like Kudzu).  

This would address one of the key issues that people are always
complaining about regarding RPMs.

Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Always

Steps to Reproduce:
1.blah, blah
2.
3.
    

Additional info:
Comment 1 Jeff Johnson 2003-11-30 10:03:15 EST
Ick. No way, rpm is intended for unattended batch builds.
Putting a timer on input will not solve all possible cases,
there will always be someone who complains that rpm is broke
because timer has not expired while someone else is complaining
that timer is expirong too fast.

Edit the spec file, do what you want with a text editor, instead.

Note You need to log in before you can comment on or make changes to this bug.