Bug 110978 - Nautilus gives "Unsupportable Operation" Error when trying to copy a launcher into the menu- another kind of error when attempting to make a launcher by scratch.
Nautilus gives "Unsupportable Operation" Error when trying to copy a launcher...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 02:44 EST by Robert Eckhoff
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 10:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Eckhoff 2003-11-26 02:44:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I get the following:
I'll try to draw the whole picture of it in pseudo HTML... this is the
window that pops up.

<html>
<title>
Error while copying.
</title>
<body>
Error "Unsupported operation" while copying.
Would you like to continue?
</body> 
<button>Skip</button>
<button>Cancel</button>
<button>Retry</button>
</html>

And so I hit retry but the copying procedure never happens

Version-Release number of selected component (if applicable):
nautilus-2.4.0-7

How reproducible:
Always

Steps to Reproduce:
  I have a launcher Icon of Eclipse on my desktop.  I want an Eclipse
Icon in my- startmenu(the fedora hat) -> Programming - folder.  First
I attempt to copy my existing launcher into the menu.  I double click
on my Home button (on the desktop-starting nautilus) -> GO ->
Start-here -> Applications -> Programming.  I drag my existing Eclipse
Icon from the desktop to the open window

Actual Results:  I get the following:
I'll try to draw the whole picture of it in pseudo HTML... this is the
window that pops up.

<html>
<title>
Error while copying.
</title>
<body>
Error "Unsupported operation" while copying.
Would you like to continue?
</body> 
<button>Skip</button>
<button>Cancel</button>
<button>Retry</button>
</html>

Expected Results:  The launcher file should have been placed in the
applications://Programming folder

Additional info:

I also cannot create a launcher file from scratch in any of the
applications folders.  When I am my regular user, I right click in the
applications://Programming folder where my Emacs is currently residing
and Left-Click on Create Launcher.  Nothing Happens.  But if I su into
root and start nautilus go to the same folder and click the same stuff
I get the following console output:
I comment here with /** */
[root@localhost myName]# nautilus

/**
This is just the stuff I get for using X as a root
*/
(nautilus:8795): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.

/**
--------------------------------------------------------------
This is the point where I have right-click -> Create Launcher
*/
(gnome-desktop-item-edit:8810): GnomeUI-WARNING **: While connecting
to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
gnome-desktop-item-edit: applications:///Programming does not exist
Comment 1 Robert Eckhoff 2003-11-26 02:45:22 EST
Pentium II is a i686 Right? because that is what I have.
Comment 2 Robert Eckhoff 2003-11-26 02:45:50 EST
A PII
Comment 3 Robert Eckhoff 2003-11-30 01:29:15 EST
Now as a non-root user I am completely unable to get to
applications:// in Nautilus.  Though I am able to get to it as root.
There Error I get is in pseudo html:

<title>
     View Failed
</title>

<body>
     The Catalog view encountered an error while starting up.
</body>

<button> Ok </button>

WTF is happening, this bug is getting worse for no apparent reason.
Comment 4 Robert Eckhoff 2003-11-30 04:43:01 EST
All right, I found a work around.  But this Pain in the ass problem
needs to get found.  Here's my work around.
For example we'll use Eclipse just to keep this problem parallel.
[root@localhost root]# cd /usr/share/applications
[root@localhost applications]# vi eclipse.desktop
/**
make sure the name of the *.desktop file is lowercase.

then there needs to be something like this:
hit INS, then type
*/
[Desktop Entry]
Name=Eclipse
Comment=Eclipse
Exec=/opt/eclipse/./eclipse -data /home/myName/prog -vm
/usr/java/j2sdk/jre/bin/java
Icon=/opt/eclipse/icon.xpm
Type=Application
Terminal=0
MapNotify=false
Categories=Development;X-Red-Hat-Base;Application;
Encoding=UTF-8


then you need to hit ESC, then type ":w" then type ":q"
then type:

[root@localhost applications]# chmod 644 eclipse.desktop

When I hit the main menu and go to Programming, it does make an icon
pop up where I want it.

I got the correct categories to name this desktop file by 1/2
understanding the /etc/X11/desktop-menus/applications.menu file.

Now what I noticed is pretty crappy.  RedHat is violating the LSB
filesystem standard.  There is no inclusion of a
/usr/local/share/applications folder in this applications.menu file. 
That mean that any newly built programs have to deal with the
/usr/share directory when they are only supposed to deal with the
/usr/local/share directory.  In addition to this.  Assuming that there
are multiple users using a single workstation.  There is no way a
single user could customize his/her main menu the way he wants it.

Gnome should by a template copy an entire menu structure into
something like a $home/.gnome/applications folder and gnome should
only read from there the main menu stuff.  If that folder is gone or
corrupted Gnome should copy another copy of that template over into
the person's home directory. This way each person can customize
his/her own menu and if they screw up gnome will set the problems
straight. And since these .desktop files are essentially just text
files there shouldn't be a disk space problem at all by doing this.

This template would essentially just be a copy of all the *.desktop
files present in the /usr/share/applications and the *new*
/usr/local/share/applications directories.

Now since each user has his/her own main menu structure.  Nautilus
would legally be able to edit the structure through the applications:/
stuff.  The reason the adjective legally is used is that if a user
tried to edit his/her menu in the past, it was actually illegal
because root owned the /usr/share/applications directory with the
default permissions -rwx-r--r-- .

Well at the bare minimum, my initial problem needs to be fixed.  Even
as root the initial problem happened so... FIX IT PLEASE.
Comment 5 Alexander Larsson 2003-12-15 11:22:45 EST
We ship with editable vfolders (such as applications://) disabled,
since they are very unstable and buggy. Thats the cause of this problem.
Comment 6 Rubén 2004-04-17 09:43:16 EDT
I think that Fedora Team would work on that issue. I think is a really
BIG problem couldn't personalize your menu. Vfolder are unstable? Ok,
we could think about creating a tool to personalize menu as menudrake
in Mandrake.
Comment 7 Alexander Larsson 2004-10-04 10:30:15 EDT
Vfolders not being editable is a well known problem. We're working on
it, but it wont be in the gnome 2.8 release.

Note You need to log in before you can comment on or make changes to this bug.