Bug 110991 - Xinerama fails on Matrox MGA G550
Xinerama fails on Matrox MGA G550
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 07:50 EST by Dave Abbott
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 09:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Abbott 2003-11-26 07:50:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Previously (4.3.0-2) we were cleanly running
dual-headed on Matrox MGA G550 card using 
twin TFT displays.

On update to 4.3.0-2.90, first card refused
to initialise. No real clue given in the logfiles,
but downgrading to 4.3.0-2 fixed the problem.


Version-Release number of selected component (if applicable):
4.3.0-2.90

How reproducible:
Always

Steps to Reproduce:
1. Reinstall 4.3.0-2.90
2.
3.
    

Actual Results:  dual-head fails


Expected Results:  Dual-head works

Additional info:

diff of logfiles with/wo problem...

< XFree86 Version 4.3.0 (Red Hat Linux 9 release: 4.3.0-2.90.43)
< Release Date: 15 August 2003
---
> XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
> Release Date: 27 February 2003
5,6c5,6
< Build Operating System: Linux 2.4.21-2.ELsmp i686 [ELF] 
< Build Date: 07 November 2003
---
> Build Operating System: Linux 2.4.20-3bigmem i686 [ELF] 
> Build Date: 27 February 2003
9,15c9,10
< 	Before reporting any problems, please make sure you are using the most
< 	recent XFree86 packages available from Red Hat by checking for updates
< 	at http://rhn.redhat.com/errata or by using the Red Hat Network up2date
< 	tool.  If you still encounter problems, please file bug reports in the
< 	XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
< 	bugzilla at http://bugzilla.redhat.com
< 
---
> 	Before reporting problems, check http://www.XFree86.Org/
> 	to make sure that you have the latest version.
21c16
< (==) Log file: "/var/log/XFree86.0.log", Time: Wed Nov 26 11:31:58 2003
---
> (==) Log file: "/var/log/XFree86.0.log", Time: Wed Nov 26 12:23:35 2003
253a249,260
> (II) LoadModule: "dri"
> (II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
> (II) Module dri: vendor="The XFree86 Project"
> 	compiled for 4.3.0, module version = 1.0.0
> 	ABI class: XFree86 Server Extension, version 0.2
> (II) Loading sub module "drm"
> (II) LoadModule: "drm"
> (II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
> (II) Module drm: vendor="The XFree86 Project"
> 	compiled for 4.3.0, module version = 1.0.0
> 	ABI class: XFree86 Server Extension, version 0.2
> (II) Loading extension XFree86-DRI
365c372
< (II) MGA(0): I2C Monitor info: 0x846acf0
---
> (II) MGA(0): I2C Monitor info: 0x841fb70
603c610
< (II) MGA(1): I2C Monitor info: 0x86ab210
---
> (II) MGA(1): I2C Monitor info: 0x8692220
810a818,821
> (II) MGA(0): [drm] bpp: 32 depth: 24
> (II) MGA(0): [drm] Sarea 2200+664: 2864
> (WW) MGA(0): Direct rendering is not supported when Xinerama is enabled
> (EE) MGA(0): [drm] DRIScreenInit failed.  Disabling DRI.
898,901d908
< (II) Screen 0 shares mem & io resources
< (II) Screen 1 shares mem & io resources
< (II) Screen 0 shares mem & io resources
< (II) Screen 1 shares mem & io resources
Comment 1 David Balažic 2003-11-26 10:27:54 EST
"> (WW) MGA(0): Direct rendering is not supported when Xinerama is
enabled"

How about turning off DRI.

Are there any other changes on the XF86Config file ?
Comment 2 Dave Abbott 2003-11-26 11:00:48 EST
As an initial test I disabled DRI by commenting out
the 'Load "dri"' line in XF86Config. However, that
did not solve the problem. No other changes were made
to the XF86Config file. 
Comment 3 Mike A. Harris 2004-10-12 09:06:07 EDT
The "mga" driver included with XFree86 and X.Org X11 does not
support multihead on DFP displays.  It only supports multihead
on CRT displays.

The "mga" driver on the Matrox website, along with the "hallib"
module provided on Matrox's website are required to use multihead
on DFP displays.

Since we do not provide or support the proprietary hallib, nor
Matrox's downloadable driver, if you have problems with their
driver, you may wish to contact Matrox directly.  Alternatively,
the X.Org and/or XFree86 mailing lists might be useful as well.

Hope this helps.

Setting status to "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.