Bug 111006 - mc should BuildRequires: glib2-devel
mc should BuildRequires: glib2-devel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mc (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 09:14 EST by Maxim Dziumanenko
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.6.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-01 11:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2003-11-26 09:14:41 EST
Description of problem:
glib2 headers and development libs needed to build mc, thus mc
should BuildRequires: glib2-devel 

Version-Release number of selected component (if applicable):
mc-4.6.0-6

How reproducible:
Always

Steps to Reproduce:
1.rpm -e glib2-devel
2.rpmbuild --rebuild mc-4.6.0-6.src.rpm
3.Wait for build errors
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2003-11-26 14:39:19 EST
Triage->Easyfix
Comment 2 Leonard den Ottolander 2003-12-25 17:18:56 EST
I noticed this as well, although the build does continue if just
glib-devel is installed. But BuildRequires glib2-devel is probably
better than BR glib-devel.
Comment 3 Leonard den Ottolander 2003-12-25 17:21:00 EST
Sorry, I forgot to mention I am speaking of Fedora Core 1 here.
Comment 4 Leonard den Ottolander 2004-02-09 12:26:55 EST
In mc-4.6.0-8.4. This can be closed ERRATA.

Note You need to log in before you can comment on or make changes to this bug.