Bug 111020 - bad source code
bad source code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openmotif (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
: 79234 105845 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 10:25 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 11:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-26 10:25:42 EST
Description of problem:
I just tried to compile package openmotif-2_2_2-16_1 from Fedora.

The compiler said

TabBox.c:8033: warning: operation on `cnt' may be undefined
TabBox.c:8054: warning: operation on `cnt' may be undefined
TabBox.c:8316: warning: operation on `cnt' may be undefined
TabBox.c:8337: warning: operation on `cnt' may be undefined

The source code for the first one is

	rect[cnt++].height = (int)XtHeight(tab) - rect[cnt].y;

Better code would be

	rect[ cnt].height = (int)XtHeight(tab) - rect[cnt].y;
	++cnt;

I assume the other three cases are the same.


Version-Release number of selected component (if applicable):
openmotif-2_2_2-16_1 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-04-19 11:10:44 EDT
Fixed in rawhide in openmotif-2.2.3-2 or newer.
Comment 2 Thomas Woerner 2004-04-19 11:26:43 EDT
*** Bug 105845 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Woerner 2004-04-19 11:28:20 EDT
*** Bug 79234 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.