Bug 111039 - Loading of kernel modules requires -f
Summary: Loading of kernel modules requires -f
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: modutils (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 106472
TreeView+ depends on / blocked
 
Reported: 2003-11-26 16:46 UTC by Tim Burke
Modified: 2014-03-17 02:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-16 17:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:327 normal SHIPPED_LIVE Updated modutils packages available 2003-11-06 05:00:00 UTC

Description Tim Burke 2003-11-26 16:46:41 UTC
Description of problem:
Everyone knows that the kernel binary compat is a big deal in the RHEL
family.  (Well, especially for x86.)  In RHEL2.1 there was a change in
modutils to allow partner supplied kernel modules to load without
requiring the -f option.  That was done because the partners
complained that it would introduce too much support load if usage of
-f was required.

The behavior in RHEL 3 as it stands now should be modified to be
functionally comparable to RHEL2.1.  For example, to compare the major
version only, not the EXTRAVERSION if crcs are present.

Comment 2 Bill Nottingham 2003-11-26 17:29:45 UTC
Note that there was no change to allow this to work in RHEL2.1; it
just happened to work because of an upstream bug.

Comment 3 Bill Nottingham 2003-11-26 20:29:58 UTC
modutils-2.4.25-11.EL will load the modules and print the following:

Warning: kernel-module version mismatch
  loop.o was compiled for kernel version 2.4.21-4.EL
  while this kernel is version 2.4.21-4.17.EL
Warning: loading loop.o will taint the kernel: forced load
 See http://www.tux.org/lkml/#export-tainted for information about
tainted modules

Comment 4 Jay Turner 2004-01-16 17:18:27 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-327.html



Note You need to log in before you can comment on or make changes to this bug.