Bug 11104 - The `-n' flag to sort does not work properly
Summary: The `-n' flag to sort does not work properly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 11685 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-28 18:54 UTC by mw
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 13:52:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mw 2000-04-28 18:54:09 UTC
Consider the following outputs:

$ cat number
1
12
10
8

$ sort -n number
8
10
12
1

This does not look like the numerical order---the flag `-g' shows what I
wanted to see:

$ sort -g number
1
8
10
12

I do not see the problem on RH 6.1 which has textutils-2.0 and not
textutils-2.0a

Mate

Comment 1 mw 2000-04-28 21:07:59 UTC
It turns out that compiling textutils-2.0a from sources results in a sort which
does not show the bug.

# ./textutils-2.0a/src/sort -n ~mw/number
1
8
8
10
10
12

So the bug got introduced by the patches RH applied.

Mate

Comment 2 Bernhard Rosenkraenzer 2000-05-05 13:52:59 UTC
Thanks, fixed in rawhide

Comment 3 Bernhard Rosenkraenzer 2000-06-12 20:35:23 UTC
*** Bug 11685 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.