Bug 111041 - up2date hangs resolving dependencies
up2date hangs resolving dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
: 111042 (view as bug list)
Depends On:
Blocks: 124619
  Show dependency treegraph
 
Reported: 2003-11-26 11:56 EST by Matthew Saltzman
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 18:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2003-11-26 11:56:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
On attempt to install a package requiring dependencies up2date hangs
if the dependencies are not already satisfied.

Version-Release number of selected component (if applicable):
up2date-4.1.16-1

How reproducible:
Always

Steps to Reproduce:
1. Add "apt macromedia http://ruslug.rutgers.edu/macromedia/apt
fedora/1 macromedia"
2. make sure compat-libstdc++ RPM is *not* installed.
3. run "up2date flash-plugin"

Actual Results:  up2date hangs after printing "Testing package set /
solving RPM inter-dependencies..."  Ctrl-C kills the process with the
message "There was some sort of I/O error: [Errno 4] Interrupted
system call".

Expected Results:  Packages required for resolving dependencies should
be located and installed (or a graceful error exit if they cannot be
resolved).

Additional info:

Also tried with apt and with yum for livna repo and installing mplayer.
Comment 1 Matthew Saltzman 2003-11-26 12:02:59 EST
*** Bug 111042 has been marked as a duplicate of this bug. ***
Comment 2 Chris Kuivenhoven 2004-09-04 16:46:12 EDT
With Fedora Core 3 test 1 "rawhide" this seems to work fine. The
current behavior is for up2date to advise of other rpm's required to
be updated in order to satisfy dependencies, ask for permission, and
then get them as well. I believe this worked in Core 2, also. Can you
confirm?

-Chris Kuivenhoven
Comment 3 Matthew Saltzman 2004-09-04 17:14:59 EDT
Yes, it appears to work with FC2.  I just installed Frozen Bubble from
Livna and it grabbed SDL_ttf from Fedora Extras with no problem. 
(flash-plugin no longer depends on compat-libstdc++, so I couldn't try
exactly the same situation as failed oriinally.)
Comment 4 Chris Kuivenhoven 2004-09-04 18:16:56 EDT
The integration of libsilc with gaim caused up2date to obtain libsilc
for me yesterday. The only problems I have with up2date updating
packages at this point are just package dependencies where the
packages just need to be updated (and this typically just takes a day
or so) and is being tracked in another bug.

Unless you want to test further, sounds like you can mark this one as
RESOLVED. :)

Thanks for the quick followup!

-Chris
Comment 5 Matthew Saltzman 2004-09-04 18:23:56 EDT
OK Done.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.