Bug 111043 - Unable log with local users
Unable log with local users
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 12:24 EST by Pere Benavent
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 03:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pere Benavent 2003-11-26 12:24:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.4.1)
Gecko/20031114

Description of problem:
I can't log via ftp with a local user.

I've change following three things inside my vsftpd.conf:

# Allow anonymous FTP?
anonymous_enable=NO
# Uncomment this to allow local users to log in.
local_enable=YES
# You may fully customise the login banner string:
ftpd_banner=Welcome to Zozeck FTP service.

I've change ftpd_banner in order to locate which vsftpd.conf I was
using (i've found one at /etc/vsftpd.conf and another one at
/etc/vsftpd/vsftpd.conf)

If I try to log via ftp with a valid user and password vsftpd anwsers
"Login failed"



Version-Release number of selected component (if applicable):
vsftpd-1.2.0-5

How reproducible:
Always

Steps to Reproduce:
1.Edit your vsftpd.conf and put: anonymous_enable=NO and one line
below local_enable=YES
2. type as root: /etc/init.d/xinetd restart (no matter with or without
portmap started)
3. try to log via ftp from another machine with a local valid user
    

Actual Results:  Each time that I try to log with a local valid user
vsftpd server anwser:
pere@porta:~$ ftp 192.164.14.3
Connected to 192.164.14.3.
220 Welcome to Zozeck FTP service.
Name (192.164.14.3:pere): pere
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp>

Expected Results:  It should be possible to log as a valid user with
password.

Additional info:

I've done a few checks before submit this bug:

1. if I try the same configuration but trying to log as anonyous
obviously it didn't runs.
2. if I change configuration file just changing anonymous_enable=NO
and local_enable=NO and then I try an anonymous logging it runs Ok.

The /var/log/messages looks like this:
Nov 26 17:51:53 zozeck xinetd: Iniciaci�n de xinetd succeeded
Nov 26 17:51:53 zozeck xinetd[7479]: pmap_set failed. service=sgi_fam
program=391002 version=2
Nov 26 17:51:54 zozeck xinetd[7479]: xinetd Version 2.3.12 started
with libwrap loadavg options compiled in.
Nov 26 17:51:54 zozeck xinetd[7479]: Started working: 1 available service

I've look ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-1.2.1/FAQ
and there appear this problem: "Q) Help! Local users cannot log in."

I've check all this things:
A1)I've check right vsftpd.conf configuration about local_enable and
so on.
A2) I've type an "ldd vsftpd" and I've check that all libraries are on
my system.
A3) I've check that user 'ftpsecure' has a shell that appears at
/etc/shells (I've check also that ftpsecure user and nobody users
appears at my box)
A4) this point does not apply 'cause I use pam.

I've check that pmap_set (line error at my messages log) is in my box,
it belongs to portmap, and no matter that portmap it's running or it
doesn't, vsftpd fails. So I've to exclude this variable from this
issue (or I doesn't?). BTW at box which is running vsftpd if I type
pmap_set:
[root@zozeck etc]# pmap_set
pmap_set: malformed line:

I suppose this is an issue concerning pam and how vsftpd tries to
verify password from a valid user, but I don't ignore pmap_set problem.
Comment 1 Bill Nottingham 2003-11-26 12:29:38 EST
What messages do you get from pam and vsftpd when you try to log in?
Comment 2 Pere Benavent 2003-11-26 13:24:59 EST
From /var/log/vsftpd.log when fails with user+passwd

[root@zozeck log]# tail -f vsftpd.log
Wed Nov 26 19:13:39 2003 [pid 7706] CONNECT: Client "192.164.14.1"
Wed Nov 26 19:13:44 2003 [pid 7705] [pere] FAIL LOGIN: Client
"192.164.14.1"

From /var/log/vsftpd.log when runs ok using anonymous:
[root@zozeck log]# tail -f vsftpd.log
Wed Nov 26 19:15:33 2003 [pid 7730] CONNECT: Client "192.164.14.1"
Wed Nov 26 19:15:46 2003 [pid 7729] [ftp] OK LOGIN: Client
"192.164.14.1", anon password "somebody@foo.com"


From /var/log/messages, both cases with/without anoymous configuration
 if I start pormat before vsftpd doesn't appear that "pmap_set failed"

[root@zozeck log]# tail -f messages
Nov 26 19:18:38 zozeck xinetd[7804]: Exiting...
Nov 26 19:18:38 zozeck xinetd: Interrupción de xinetd succeeded
Nov 26 19:18:38 zozeck xinetd: Iniciación de xinetd succeeded
Nov 26 19:18:39 zozeck xinetd[7824]: xinetd Version 2.3.12 started
with libwrap loadavg options compiled in.
Nov 26 19:18:39 zozeck xinetd[7824]: Started working: 2 available services

Where can I look for pam information? logs?
Comment 3 Bill Nottingham 2003-11-26 14:34:12 EST
/var/log/secure

Comment 4 Pere Benavent 2003-11-27 16:48:19 EST
Ok, while I do this from client machine:

pere@porta:~$ ftp 192.164.14.3
Connected to 192.164.14.3.
220 Welcome to Zozeck FTP service.
Name (192.164.14.3:pere): pere
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp> quit
221 Goodbye.
pere@porta:~$

my /var/log/secure just write this line:
Nov 27 22:49:22 zozeck xinetd[538]: START: ftp pid=1031 from=192.164.14.1

...and excuse my ugly english...
Comment 5 Jason Commandeur 2004-01-06 16:00:38 EST
I had the same problem with Fedora Core 1.
I checked to see if the vsftpd binary used PAM
run 'ldd /usr/sbin/vsftpd' and look for 'libpam'
If it is using libpam check /etc/pam.d/

I had to copy/rename my 'vsftpd' file to just 'ftp'

service vsftpd restart

Tested and worked...

Hope this helps...
Comment 6 Radek Vokal 2004-08-23 07:30:55 EDT
Tested with vsftpd-2.0.1 and the bug didn't appear.
Comment 7 Marc Perkel 2005-02-04 15:15:02 EST
I'm having the same problem. I fried the pam file trick - vsftpd > ftp
and it did not work for me. All I get is login failures.
Comment 8 Sigmund Skjelnes 2005-03-10 15:48:21 EST
Hi!
I'd also were unable to log on as a local user, but solve the problem
by altering /etc/pam.d/vsftp to /etc/pam.d/ftp. vsftp is started with
xinetd, and the xinetd.conf file name the service as ftp, is there a
conjunction here?

Cincerely, Sigmund

Note You need to log in before you can comment on or make changes to this bug.