Bug 111058 - recompile libfontenc with -fPIC
recompile libfontenc with -fPIC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 16:00 EST by Ngo Than
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-27 08:00:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2003-11-26 16:00:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
libfontenc needs to be rebuild ith fPIC. Rebuild kdebase-3.1.93 in fc2
tree breaks with:

/usr/bin/ld: /usr/X11R6/lib64/libfontenc.a(fontenc.o): relocation
R_X86_64_32S can not be used when making a shared object; recompile
with -fPIC
/usr/X11R6/lib64/libfontenc.a: could not read symbols: Bad value



Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
rebuild kdebase-3.1.93 in fc2 tree

Actual Results:  /usr/bin/ld:
/usr/X11R6/lib64/libfontenc.a(fontenc.o): relocation R_X86_64_32S can
not be used when making a shared object; recompile with -fPIC
/usr/X11R6/lib64/libfontenc.a: could not read symbols: Bad value

Expected Results:  it should be build without this problem

Additional info:

Here is a patch, which should fix this problem

--- XFree86-4.3.0/xc/lib/fontenc/Imakefile.orig 2003-11-24
21:44:15.000000000 +0100
+++ XFree86-4.3.0/xc/lib/fontenc/Imakefile      2003-11-24
22:39:44.000000000 +0100
@@ -22,6 +22,8 @@
 #define IncSubdir X11
 #define IncSubSubdir fonts

+#define IncludeSharedObjectInNormalLib
+
 #include <Library.tmpl>

 #if GzipFontCompression
Comment 1 Ngo Than 2003-11-27 08:00:17 EST
It's now fixed in Xfree86-4.3.0-44. thanks Mike!
Comment 2 Jay Turner 2004-01-16 11:58:47 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-406.html

Note You need to log in before you can comment on or make changes to this bug.