Bug 111080 - bad source code
bad source code
Status: CLOSED DUPLICATE of bug 106301
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 05:08 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-27 05:08:28 EST
Description of problem:
I just tried to compile package ppp-2.4.1-15 from Fedora.

The compiler said

1.

pppdump.c:166: warning: too few arguments for format
pppdump.c:395: warning: too few arguments for format

The source code is

            printf("?%.2x\n");

Looks like a missing number for the %x format specifier.

2.

pppdump.c:421: warning: `return' with no value, in function returning
non-void
pppdump.c:424: warning: `return' with no value, in function returning
non-void

The source code is


handle_ccp(cp, dp, len)
    struct pkt *cp;
    u_char *dp;
    int len;
{
    int clen;
    struct compressor **comp;

    if (len < CCP_HDRLEN)
        return;

Suggest make return type of function handle_ccp into "void".





Version-Release number of selected component (if applicable):
ppp-2.4.1-15 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-06-21 06:41:11 EDT

*** This bug has been marked as a duplicate of 106301 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.