Bug 1111104 - scheduling policy is not being updated
Summary: scheduling policy is not being updated
Keywords:
Status: CLOSED DUPLICATE of bug 1118384
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Doron Fediuck
QA Contact: Shai Revivo
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-19 09:16 UTC by Ohad Basan
Modified: 2016-02-10 20:13 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 11:51:56 UTC
oVirt Team: SLA


Attachments (Terms of Use)

Description Ohad Basan 2014-06-19 09:16:31 UTC
Description of problem:
Running rhevm-cli-3.4.0.6-3.el6ev.noarch with rhevm 3.5 (master)
trying to update policy to powersaving

update cluster RestCluster7 --scheduling_policy-thresholds-low 20 --scheduling_policy-policy 'power_saving' --correlation_id 316 

doesn't update and the policy remains as it were before.

Comment 2 Martin Sivák 2014-06-30 14:43:27 UTC
Hi Ohad,

can you please test with matching versions of cli and engine? We did some changes to the REST API with regards to scheduling policy and we would like to know if it works 3.4-3.4 and 3.5-3.5.

Comment 3 Ohad Basan 2014-07-02 08:07:13 UTC
Hello Juan

now that there is a 3.5 tag available
any chance of providing us a brew build of rhevm-cli 3.5?

thanks!

Comment 8 Doron Fediuck 2014-08-04 14:44:12 UTC
Ohad, can you please re-test as Martin asked in comment 2?

Comment 9 Ohad Basan 2014-08-05 11:42:16 UTC
Nelly

I dont see that test in the new unittest regression_mixed job.

it's running with the latest rhevm-cli from brew.
http://jenkins-ci.eng.lab.tlv.redhat.com/job/update_repo_3.5_factory/1434/

The only test that seems to be related is:
http://jenkins-ci.eng.lab.tlv.redhat.com/job/rhevm_3.5_automation_infra_one_host_restapi_mixed_nfs_cli_factory/372/testReport/junit/regression_infra.component.test_clusters/024-TestCaseCluster;t24_update_cluster_scheduling_policy/TestCaseCluster_t24_update_cluster_scheduling_policy/

is it the same test?

if it is, then it's still failing

Comment 10 Nelly Credi 2014-08-06 05:33:58 UTC
this bug is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1118384 (opened in upstream) & it was fixed in the previos build --> REST & Java are working (run the same test on them and you will see it passes or see our Jenkins http://jenkins.qa.lab.tlv.redhat.com:8080/view/Infra/job/3.5-regression_mixed/68/testReport/)

SDK & CLI are still failing but I believe it is related to this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1122546 - update fails in SDK & CLI for several entities

Comment 11 Doron Fediuck 2014-08-13 10:18:08 UTC
(In reply to Nelly Credi from comment #10)
> this bug is a duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1118384 (opened in upstream) &
> it was fixed in the previos build --> REST & Java are working (run the same
> test on them and you will see it passes or see our Jenkins
> http://jenkins.qa.lab.tlv.redhat.com:8080/view/Infra/job/3.5-
> regression_mixed/68/testReport/)
> 
> SDK & CLI are still failing but I believe it is related to this bug:
> https://bugzilla.redhat.com/show_bug.cgi?id=1122546 - update fails in SDK &
> CLI for several entities

Since Bug 1122546 is in modified can you check if it resolves the problem?
Either way, can we close this issue as a dup of 1118384?

Comment 12 Nelly Credi 2014-08-13 13:40:43 UTC
It can only be tested in dev CI
Ohad, can you please check it?
& is it ok to close this bug as a duplicate? as I wrote it was verified in upstream with REST API

Comment 13 Ohad Basan 2014-09-01 11:51:56 UTC
we can close it.
it's working properly

*** This bug has been marked as a duplicate of bug 1118384 ***


Note You need to log in before you can comment on or make changes to this bug.