Bug 111113 - libcroco should BuildRequires: libgnomeui-devel. libcroco-devel should Requires: libgnomeui-devel
libcroco should BuildRequires: libgnomeui-devel. libcroco-devel should Requi...
Product: Red Hat Raw Hide
Classification: Retired
Component: libcroco (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-11-27 11:31 EST by Maxim Dziumanenko
Modified: 2013-04-02 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-11 04:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2003-11-27 11:31:44 EST
Description of problem:
1. libgnome headers and development libs needed to build libcroco
2. /usr/lib/pkgconfig/libcroco.pc references to libgnomeui
Thus libcroco should BuildRequires: libgnomeui-devel,
libcroco-devel should Requires: libgnomeui-devel

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpm -e libgnomeui-devel
2.rpmbuild --rebuild libcroco-0.3.0-1.src.rpm
3.Wait for build errors
Actual results:

Expected results:

Additional info:
Comment 1 Miloslav Trmac 2003-11-28 10:56:52 EST
Comment 2 Warren Togami 2004-04-07 21:08:22 EDT
jrb, could you please confirm this?  This may be good to get rid of
unnecessary BuildRequires in other packages.
Comment 3 Warren Togami 2004-04-11 04:59:57 EDT
Should hit rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.