Bug 1111229 - image uploader's rpm should provide required user on install if missing
Summary: image uploader's rpm should provide required user on install if missing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-image-uploader
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-19 14:03 UTC by Alissa
Modified: 2014-10-17 12:25 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1129382 (view as bug list)
Environment:
Last Closed: 2014-10-17 12:25:31 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31065 master MERGED ovirt-image-uploader: Add creation of VDSM user Never
oVirt gerrit 32156 ovirt-image-uploader-3.5 MERGED ovirt-image-uploader: Add creation of VDSM user Never
oVirt gerrit 32296 master MERGED ovirt-image-uploader: Add creation of KVM group Never
oVirt gerrit 32301 ovirt-image-uploader-3.5 MERGED ovirt-image-uploader: Add creation of KVM group Never

Description Alissa 2014-06-19 14:03:46 UTC
Description of problem:

The uploader requires existence of user 'vdsm' on the machine where its executed.
Its rpm doesn't check/add the required user, so if that user doesn't exist on the machine where it runs  - the uploader fails.(for example - ovirt-engine machine where the engine was built from source and doesn't require user vdsm to exist)
The error at failure:
"ERROR: A user named vdsm with a UID and GID of 36 must be defined on the system to mount the export storage domain on myexport as Read/Write"


Version-Release number of selected component (if applicable):
3.4

How reproducible:
when user vdsm doesn't exist on the machine where the uploader runs.


Expected results:
either there's no need to have user 'vdsm' or the uploader adds it upon installation.

Additional info:

Comment 1 Sandro Bonazzola 2014-06-19 14:08:05 UTC
Lev, you can find examples for checking user and group existence and code for creating them within the spec file in vdsm and ovirt-engine projects spec files.

Comment 2 Sandro Bonazzola 2014-08-05 11:35:36 UTC
Please clone the BZ to iso uploader for tracking it too.

Comment 3 Lev Veyde 2014-08-05 12:32:13 UTC
(In reply to Sandro Bonazzola from comment #2)
> Please clone the BZ to iso uploader for tracking it too.

Can't do - there is no ovirt-iso-uploader component in oVirt.
And since the patch is basically the same I think it's OK to track both in one bug.

Comment 4 Jiri Belka 2014-09-16 09:03:02 UTC
ok, ovirt-image-uploader-3.5.0-0.1.master.20140905074913.git9639d6c.el6.noarch

Comment 5 Sandro Bonazzola 2014-10-17 12:25:31 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.