Bug 111125 - gnome-python2 source package build errors
gnome-python2 source package build errors
Status: CLOSED DUPLICATE of bug 110929
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-python2 (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 13:38 EST by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 23:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified spec file (9.09 KB, text/plain)
2003-11-27 13:46 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-11-27 13:38:17 EST
Description of problem:
I rebuild the gnome-python-1.99.14-5 source rpm and I've got some
packages:
gnome-python-1.99.14-5.i386.rpm
gnome-python-applet-1.99.14-5.i386.rpm
gnome-python-bonobo-1.99.14-5.i386.rpm
gnome-python-canvas-1.99.14-5.i386.rpm
gnome-python-gconf-1.99.14-5.i386.rpm
gnome-python-gnomevfs-1.99.14-5.i386.rpm
gnome-python-gtkhtml-1.99.14-5.i386.rpm
gnome-python-nautilus-1.99.14-5.i386.rpm
and the boring gnome-python-debuginfo-1.99.14-5.i386.rpm
All the compilation process is flawless but some packages
(gnome-python-applet-1.99.14-5.i386.rpm,
gnome-python-nautilus-1.99.14-5.i386.rpm,
gnome-python-canvas-1.99.14-5.i386.rpm,
gnome-python-1.99.14-5.i386.rpm) have the same file in the same
position causing conflict at the moment of installation.
Precisely the files are:
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.py
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyc
/usr/lib/python2.2/site-packages/gtk-2.0/gnome/__init__.pyo

Version-Release number of selected component (if applicable):
1.99.14-5

How reproducible:
rpmbuild --rebuild --target=i386 gnome-python-1.99.14-5.src.rpm
cd $YOUR_BINARY_DIRECTORY
rpm -ivh gnome-python-*i386.rpm 

Steps to Reproduce:
1.rpmbuild --rebuild --target=i386 gnome-python-1.99.14-5.src.rpm
2.cd $YOUR_BINARY_DIRECTORY
3.rpm -ivh gnome-python-*i386.rpm
  
Actual results:
Conflict message error.

Expected results:
Normal installation

Additional info:
I have modified the spec file to build the package correcly, it's in
the attachment
Comment 1 Need Real Name 2003-11-27 13:46:46 EST
Created attachment 96229 [details]
Modified spec file
Comment 2 Matt Wilson 2003-11-27 18:15:02 EST

*** This bug has been marked as a duplicate of 110929 ***

Note You need to log in before you can comment on or make changes to this bug.