Bug 111127 - No kernel module for 3com 3C940 NIC
Summary: No kernel module for 3com 3C940 NIC
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
: 112880 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-27 19:27 UTC by Matt Whiteley
Modified: 2014-03-17 02:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 20:34:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adds sk98lin to pcitable for proper 3Com 940 detection (1.48 KB, patch)
2004-02-21 06:32 UTC, Justin M. Forbes
no flags Details | Diff

Description Matt Whiteley 2003-11-27 19:27:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
The network card (3com 3C940) on the Asus P4P800 Deluxe (and others)
is not recognized during install.

The driver source code is available from the asus website at:
http://www.asus.com/pub/ASUS/lan/3com/3c940/046_Linux.zip

The driver compiles under Fedora Core 1.  

Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2115.nptl.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1.Run Fedora Core Installer
2.
3.
    

Actual Results:  NIC not recognized, no networking.

Expected Results:  NIC recognized, networking enabled.

Additional info:

All files in the driver release are licensed under the GPL.

If a module was included in the kernel, it would upgrade with the
kernel each time, and not have to be rebuilt locally.

Comment 1 Justin M. Forbes 2004-01-20 04:41:22 UTC
Module should be included in the kernel, modprobe sk98lin.  Need to
update so that the onboard 940s are properly recognized.

Comment 2 Bill Nottingham 2004-01-28 19:21:42 UTC
*** Bug 112880 has been marked as a duplicate of this bug. ***

Comment 3 Justin M. Forbes 2004-02-21 06:32:53 UTC
Created attachment 97899 [details]
Patch adds sk98lin to pcitable for proper 3Com 940 detection

Comment 4 Dave Jones 2004-06-19 14:41:24 UTC
this should have been fixed ages ago. Bill ?


Comment 5 Justin M. Forbes 2004-06-21 15:59:02 UTC
This is fixed in the current shipping FC2 hwdata

cat /usr/share/hwdata/pcitable | grep sk98lin
0x10b7  0x1700  "sk98lin"       "3Com Corporation|3c940
10/100/1000Base-T [Marvell]"

Comment 6 Bill Nottingham 2004-06-28 20:34:42 UTC
Was fixed in an update too.


Note You need to log in before you can comment on or make changes to this bug.