Bug 111128 - tuxracer cannot find data files and quits
tuxracer cannot find data files and quits
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: tuxracer (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 18:30 EST by David Mark North
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 18:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mark North 2003-11-27 18:30:37 EST
Description of problem:
tuxracer fails to find data files and quits

Version-Release number of selected component (if applicable):
installed from fedora core 1 disks

How reproducible:
Every time

Steps to Reproduce:
1. select tuxracer from games menu
2. or type 'tuxracer' into terminal
3. window will blank, then return stating data files not found (if
you used the terminal).
  
Actual results:
tuxracer fails to start

Expected results:
tuxracer starts

Additional info:
The rpm installs tuxracer to /usr/share/tuxracer but the program
expects to find its data files in /usr/share/games/tuxracer. Either
changing the config, moving the data files to /usr/share/games (which 
did not exist on my system) or making a symlink from
/usr/share/games/tuxracer to /usr/share/tuxracer does the trick.
Comment 1 Alan Cox 2004-06-16 11:33:57 EDT
I've extensively tested tuxracer in FC1 and FC2 and can't duplicate this
Comment 2 Ngo Than 2004-10-11 18:24:55 EDT
sorry, i cannot reproduce it in FC1, FC2 and FC3. it works for me
Comment 3 David Mark North 2004-10-11 18:33:12 EDT
After seeing these comments I had a "duh." When doing a new install I
usually copy over various ~/.files, one of which is a .tuxracer/ that
started somewhere in prehistory.

So I looked and sure enough it indicates the directory for the
datafiles, which is not the same as that chosen by Fedora. My blunder;
sorry for the bogus report.

"Works for me too, now"

Dave North 

Note You need to log in before you can comment on or make changes to this bug.