Bug 111146 - wrong recognition of chipset
wrong recognition of chipset
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-28 10:02 EST by American Stores
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-30 23:21:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description American Stores 2003-11-28 10:02:36 EST
Description of problem: Wrong recognition of VIA km266 chipset 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
when installing, it recognizes my chipset as a km133 chipset and uses 
the wrong driver, I can only get it to install in text mode. The 
chipset is really a km266 chipset and it's an MSI board. Is there a 
configurator that i can use to change these values post-install as in 
xf86config in redhat 8.0?
Comment 1 Jeremy Katz 2003-12-16 18:42:32 EST
What driver specifically does it recognize incorrectly?
Comment 2 American Stores 2003-12-17 08:17:22 EST
The video card driver
Comment 3 Jeremy Katz 2003-12-17 10:26:08 EST
What driver is it supposed to use and which one did it use?  Can you
also provide lspci -vn information from the machine?
Comment 4 American Stores 2003-12-17 10:55:13 EST
The chipset the board uses is the VIA km266 so the video is provided
by an S3 Graphics ProSavage8™ 2D/3D Accelerator. 

I am currently back on Redhat 8 how do I check which driver it is
using? I suspect that it is the generic Vesa driver on redhat 8.0.


lspci -vn returned the following:

00:00.0 Class 0600: 1106:3116
        Subsystem: 1106:3116
        Flags: bus master, 66Mhz, medium devsel, latency 8
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

00:01.0 Class 0604: 1106:b091
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: e0000000-e00fffff
        Prefetchable memory behind bridge: d8000000-dfffffff
        Capabilities: [80] Power Management version 2

00:10.0 Class 0c03: 1106:3038 (rev 80)
        Subsystem: 1106:3038
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at a000 [size=32]
        Capabilities: [80] Power Management version 2

00:10.1 Class 0c03: 1106:3038 (rev 80)
        Subsystem: 1106:3038
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at a400 [size=32]
        Capabilities: [80] Power Management version 2

00:10.2 Class 0c03: 1106:3038 (rev 80)
        Subsystem: 1106:3038
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at a800 [size=32]
        Capabilities: [80] Power Management version 2

00:10.3 Class 0c03: 1106:3104 (rev 82) (prog-if 20)
        Subsystem: 1462:7380
        Flags: bus master, medium devsel, latency 32, IRQ 5
        Memory at e0100000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

00:11.0 Class 0601: 1106:3177
        Subsystem: 1106:3177
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:11.1 Class 0101: 1106:0571 (rev 06) (prog-if 8a [Master SecP PriP])
        Subsystem: 1462:7380
        Flags: bus master, medium devsel, latency 32
        I/O ports at ac00 [size=16]
        Capabilities: [c0] Power Management version 2

00:11.5 Class 0401: 1106:3059 (rev 50)
        Subsystem: 1462:7380
        Flags: medium devsel, IRQ 10
        I/O ports at b000 [size=256]
        Capabilities: [c0] Power Management version 2

00:12.0 Class 0200: 1106:3065 (rev 74)
        Subsystem: 1462:738c
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at b400 [size=256]
        Memory at e0101000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 2

01:00.0 Class 0300: 5333:8d04
        Subsystem: 1462:7389
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 11
        Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [80] AGP version 2.0
Comment 5 Bill Nottingham 2003-12-17 12:57:30 EST
It's using the 'savage' driver; if that's not the right one, that may
mean that no driver exists.
Comment 6 Bill Nottingham 2004-01-29 02:00:26 EST
The 'ProSavage KM133' maps to the savage driver. If the savage driver
does not work, that's an X bug (because even if we changed the
identification to say KM266, it would still be the savage driver.)
Comment 7 Jef Spaleta 2004-01-30 23:21:27 EST
I'm going to close this as resolution upstream
Mharris has made a pretty lengthy reply about the savage driver issues
here: http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=90419

upstream bugzilla does have a relevant report for Fedora Core 1:
http://bugzilla.xfree86.org/show_bug.cgi?id=959


Comment 8 Mike A. Harris 2004-09-01 07:17:46 EDT
Status update: No movement in upstream bug report.  Someone might
want to ping the X.Org developers if this issue is still occuring
in current xorg-x11 sources, or discuss the issue on X.Org mailing
lists, in hopes it gets attention.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.