Bug 111186 - RHEL3 perl cannot build without perl installed
RHEL3 perl cannot build without perl installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
3.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-29 02:19 EST by Daniel Wittenberg
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version: perl-5.8.0-89.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 16:28:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Wittenberg 2003-11-29 02:19:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
You can't rebuild the perl src.rpm properly

perl-5.8.0-88.4.src.rpm

$ rpmbuild -ba perl.spec
.
.
gcc: error while loading shared libraries:
/usr/src/redhat/BUILD/perl-5.8.0/libperl.so: cannot open shared object
file: No such file or directory
make: *** [miniperl] Error 127
error: Bad exit status from /var/tmp/rpm-tmp.57500 (%build)
    Bad exit status from /var/tmp/rpm-tmp.57500 (%build)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba perl.spec
2.
3.
    

Actual Results:  gcc: error while loading shared libraries:
/usr/src/redhat/BUILD/perl-5.8.0/libperl.so: cannot open shared object
file: No such file or directory
make: *** [miniperl] Error 127
error: Bad exit status from /var/tmp/rpm-tmp.57500 (%build)
    Bad exit status from /var/tmp/rpm-tmp.57500 (%build

Additional info:
Comment 1 Suzanne Hillman 2003-12-03 14:54:09 EST
I am unable to reproduce this here. I'm wondering if it might have
something to do with the spec file you are using, or possibly how the
machine was installed (what packages, etc). Can you give more info on
this?
Comment 2 Suzanne Hillman 2003-12-03 17:36:54 EST
As per an email received from the submitter:

This system was built with kickstart, using specific packages.  I then
downloaded the perl src.rpm, just modified the otherlibdirs, and tried
to rebuild.  Would you like the full installed RPM list and the one
line in the spec I changed?
Comment 3 Chip Turner 2003-12-08 12:05:44 EST
sounds like the package requires perl to be installed to build
properly, despite some efforts to not make this the case.  this is a
low priority bug and will be fixed if an opportunity presents itself,
but it will likely be rather slow unless assisted with external patches.
Comment 4 Jason Vas Dias 2005-11-10 16:28:01 EST
Sorry for the long delay in processing this bug.
It appears this bug is no longer a problem for RHEL-3-U6 / perl-5.8.0-89.10+ -
perl builds fine from the src.rpm without perl being installed.

Note You need to log in before you can comment on or make changes to this bug.