Bug 111195 - sqltypes.h from postgresql and unixODBC conflict
Summary: sqltypes.h from postgresql and unixODBC conflict
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Jee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 111811 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-29 17:13 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 16:33:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-11-29 17:13:22 UTC
Description of problem:

With postfix 7.4 sqltypes.h seems to conflict with the one from
unixODBC-devel.

file /usr/include/sqltypes.h from install of postgresql-devel-7.4-3
conflicts with file from package unixODBC-devel-2.2.5-9

Comment 1 Joe Orton 2003-12-01 14:18:44 UTC
This is breaking any packages which build against unixODBC.  Please
fix ASAP!

Comment 2 David Jee 2003-12-01 14:49:38 UTC
Working on a fix.

Comment 3 Ngo Than 2003-12-03 11:12:20 UTC
David,

perhaps we should install the header files from ecpg in subfolder, for
example: /usr/include/ecpg.



Comment 4 David Jee 2003-12-04 16:33:50 UTC
The ecpg headers are moved to /usr/include/pgsql/ecpg in
postgresql-7.4-4.  That should take care of the conflict.

Comment 5 Joe Orton 2003-12-04 16:49:12 UTC
Thanks David.  I'm building a newer unixODBC to try and get the right
sqltypes.h into the buildroots.

Comment 6 David Jee 2003-12-10 14:57:33 UTC
*** Bug 111811 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.