Bug 11122 - Kudzu not accepting input when detecting new hardware on laptop
Kudzu not accepting input when detecting new hardware on laptop
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
: 16862 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-04-30 11:08 EDT by craig
Modified: 2014-03-16 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-15 06:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description craig 2000-04-30 11:08:11 EDT
The kudzu that ships with Redhat 6.2 linux does not accept input on bootup
when detecting new hardware on my laptop. The laptop is a Compaq LTE 5300.
If new hardware is detected, it will wait thirty seconds, and not allow any
keypress to interrupt it to continue it's detection.
Comment 1 Holger Schurig 2000-09-14 05:44:34 EDT
My laptop (Mitac 5027) has a similar behavior. During installation time the
keyboard controller stops working.

Noteworthy: Red Hat 6.1 installer worked. Red Hat 6.1 itself also worked, but
only when I did let "kudzu" execute during system startup.
Comment 2 Holger Schurig 2000-09-14 05:47:44 EDT
Oh, I forgot: I am using boot-20000407.img for my bootfloppy.
Comment 3 Bill Nottingham 2000-09-14 11:36:37 EDT
*** Bug 16862 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2000-09-14 11:42:17 EDT
The best bet to see if this is fixed is if you could
download the pinstripe kudzu SRPM, rebuild it, and
try running it on your 6.1 system and see if that helps.
Comment 5 Holger Schurig 2000-09-15 02:22:43 EDT
I will do this ASAP.

In the meantime just note that "mouseconfig" on this laptop also locks the keyboard, probably while trying to auto-detecting the mouse. So I will test 
"mouseconfig" from pinstripe, too. Should I continue this thread or should I then start a new bug-thread on the pinstripe part of bugzilla?
Comment 6 Holger Schurig 2000-09-15 06:50:20 EDT
I finally got RH 6.2 installed on this system: I've done a kickstart
installation without any user interaction. That worked.

Same symptons here: both kudzu (and mouseconfig, which uses kudzu) killed my
keyboard. Not the system, I was able to telnet into the laptop.

The I have done what you advised: to get the kudzu SRPM from pinstripe. I have
compiled and installed it (as well as the pinstripe mouseconfig). Now it works.

Now I would be happy if I would knew a URL for a description to make my own
installation disk, one where the kudzu libs were the new ones so that I can
install RH 6.2 in a more normal way on my box ...      (I know lots of docs on
how to make your own Red Hat CD, but none for a install-boot ...)
Comment 7 Bill Nottingham 2001-02-01 18:32:17 EST
This is something we've tried to fix, and failed. It's
basically impossible to fix without the hardware in front
of us.

Note You need to log in before you can comment on or make changes to this bug.