Bug 111231 - Incorrect detection of Intel i810 sound chipset
Incorrect detection of Intel i810 sound chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-soundcard (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-30 23:28 EST by Steve Miller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 12:22:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Miller 2003-11-30 23:28:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have an Intel D865PERL Motherboard, and it comes with an Intel i810
chipset for the sound.  When firstboot ran, it detected the sound and
placed the driver/module 'i810_audio' into the kernel.  However, this
file does not exist ANYWHERE in my computer, nor off the installation
ISOs.  redhat-config-sound also detects this as i810_audio, and warns
me that said driver could not be loaded and this soundcard may not be
compatible with RedHat Linux.  Also, on my previous install of RedHat
9, this was a problem, however all I needed to do was build the ALSA
drivers for intel8x0, and simply modprobe them into the kernel, and it
worked.  I've tried several times to do this with Fedora Core, a few
times with some small success, but everytime I reboot, it goes back
and tells me that it's still trying to load i810_audio again.  I've
tried editing modules.conf to load the correct module in, but for some
reason redhat-config-soundcard is persistent (and successful) in
changing everything back to i810_audio.  If I don't reboot the
computer, and I painstakingly modprobe the correct drivers in each
time the computer starts, it works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot computer
2. Run redhat-config-sound
3. Realize that it's still using i810_audio
4. modprobe in the correct drivers
5. Pray that I don't need to reboot
    

Actual Results:  I can temporarily fix the problem, and if I reboot I
need to repeat those steps.  I am looking for a permanent fix.

Expected Results:  Should accept and use the changes in the driver
change, as in RH9.

Additional info:
Comment 1 Brent Fox 2004-03-11 12:22:05 EST
Should be fixed with Fedora Core 2 since we are switching to ALSA for
all sound modules.
Comment 2 Jim Robison-Cox 2004-11-04 21:47:23 EST
I am having this same problem with fc2 running on a Dell Dimension
with the Intell i810 sound card.  The really odd thing is that I have
fc1 installed in another partition.  It has always found the sound
card and loaded a driver which works.  I did check another bug report
where someone was embarassed to admit that the problem was having
Volume turned down. So I've tried to check Volume, but it says "No
soundcard detected" hence, no volume to set.

 system-config-soundcard finds the card and says:
  Vendor: Intel
  Model: 82801BA/BAM AC'97 Audio
  Module: snd-intel8x0
When I click to play the test sound, nothing comes out.
I get these errors:
amixer: Mixer attach default error: No such device
amixer: Mixer attach default error: No such device
sox: Can't open output file '/dev/dsp': No such device
-9

 (There is a /dev/dsp directory)

I also tried 
  alsactrl restore
    but nothing changes.

What other files hold clues?   /etc/modprobe.conf is just one line:

alias eth0 e100

Note You need to log in before you can comment on or make changes to this bug.