Bug 111254 - nested assignment in assert
nested assignment in assert
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 09:37 EST by d.binderman
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: squid-2.5.STABLE5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 17:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-12-01 09:37:34 EST
Description of problem:
I just tried to compile package squid-2.5.STABLE3-0 from Fedora.

The compiler said

1.

ntlm/auth_ntlm.c(683): warning #187: use of "=" where "==" may have
been intended

The source code is

    assert(auth_user->auth_type = AUTH_NTLM);

This code might be better as 

    assert(auth_user->auth_type == AUTH_NTLM);

Putting assignments in asserts is not recommended. The assignment
will disappear when asserts are switched off by the -DNDEBUG option.


Version-Release number of selected component (if applicable):
squid-2.5.STABLE3-0 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Fenlason 2004-04-05 17:22:00 EDT
I included a patch for this in the latest rawhide squid rpm
Comment 2 Henrik Nordstrom 2004-04-06 10:01:58 EDT
Patch merged into upstream, thanks to a very observant user who
noticed this patch in Fedora.

Regards
Henrik Nordström
Squid HTTP Proxy project

Note You need to log in before you can comment on or make changes to this bug.