Bug 111306 - does not recognize the ATI 9200SE adapter
does not recognize the ATI 9200SE adapter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 111307 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 16:46 EST by Gene Czarcinski
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.102-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 02:15:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-12-01 16:46:38 EST
Description of problem:

The config program (and the installer) do not recognize the Powered by
ATI / built by Gigabyte 9200 SE video adapter although XFree86 does
recognize it and works.

The lspci -n is:

01:00.0 Class 0300: 1002:5964 (rev 01)
01:00.1 Class 0380: 1002:5d44 (rev 01)
------------------------------------------------------------------
The lspci -v is:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown
device 5964 (rev 01) (prog-if 00 [VGA])
        Subsystem: Giga-byte Technology: Unknown device 4018
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 11
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c000 [size=256]
        Memory at e5000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
        Capabilities: [50] Power Management version 2
 
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5d44
(rev 01)
        Subsystem: Giga-byte Technology: Unknown device 4019
        Flags: 66Mhz, medium devsel
        Memory at d8000000 (32-bit, prefetchable) [disabled] [size=128M]
        Memory at e5010000 (32-bit, non-prefetchable) [disabled]
[size=64K]
        Capabilities: [50] Power Management version 2
---------------------------------------------------------------------
The lspci -vv is:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown
device 5964 (rev 01) (prog-if 00 [VGA])
        Subsystem: Giga-byte Technology: Unknown device 4018
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), cache line size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at c000 [size=256]
        Region 2: Memory at e5000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
                Status: RQ=255 SBA+ 64bit- FW+ Rate=x1,x2
                Command: RQ=0 SBA+ AGP- 64bit- FW- Rate=<none>
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5d44
(rev 01)
        Subsystem: Giga-byte Technology: Unknown device 4019
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Region 0: Memory at d8000000 (32-bit, prefetchable) [disabled]
[size=128M]
        Region 1: Memory at e5010000 (32-bit, non-prefetchable)
[disabled] [size=64K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
--------------------------------------------------------------------

And the relevant part of /var/log/XFree86.log is:

        ATI Radeon 9200 5961 (AGP), ATI Radeon 9200 5962 (AGP),
        ATI Radeon 9200 5963 (AGP), ATI Radeon 9200 5964 (AGP),
        ATI Radeon M9+ 5968 (AGP), ATI Radeon M9+ 5969 (AGP),
        ATI Radeon M9+ 596A (AGP), ATI Radeon M9+ 596B (AGP),
        ATI Radeon 9500 AD (AGP), ATI Radeon 9500 AE (AGP),
        ATI Radeon 9500 AF (AGP), ATI FireGL Z1/X1 AG (AGP),
        ATI Radeon 9700 Pro ND (AGP), ATI Radeon 9700/9500Pro NE (AGP),
        ATI Radeon 9700 NF (AGP), ATI FireGL X1 NG (AGP),
        ATI Radeon 9600 AP (AGP), ATI Radeon 9600 Pro AR (AGP),
        ATI Radeon Mobility M10 NP (AGP), ATI FireGL (R350) AK (AGP),
        ATI Radeon 9800 NH (AGP), ATI FireGL (R350) NK (AGP)
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1)
found
(--) Chipset ATI Radeon 9200 5964 (AGP) found
Comment 1 Brent Fox 2004-01-16 18:44:53 EST
I added an entry to pci.ids and pcitable for the 1002:5964 device.  I
did not add the 1002:5d44 since I'm not sure what the exact
description of that device is.  I'm guessing it's the TV out.  

The VGA device should be detected with hwdata-0.102-1.  Thanks for
your report.

notting: Should we investigate more and find out what the 5d44 device
does?  I'm not sure how to add that correctly to the tables.
Comment 2 Bill Nottingham 2004-01-16 19:41:26 EST
It's just the secondary PCI device. Lots of new radeons have them.
Comment 3 Bill Nottingham 2004-01-29 01:50:18 EST
*** Bug 111307 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2004-01-29 02:15:50 EST
Fixed in 0.102-1.

Note You need to log in before you can comment on or make changes to this bug.