Bug 111319 - SNMP perl module segfaults when using asynch callbacks and GETBULK requests
SNMP perl module segfaults when using asynch callbacks and GETBULK requests
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 19:11 EST by Kaj J. Niemi
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-10 09:38:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff for SNMP.xs preventing segmentation faults while using callbacks (1.18 KB, patch)
2003-12-01 19:13 EST, Kaj J. Niemi
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2003-12-01 19:11:43 EST
Description of problem:

Attached is a fix for SNMP perl module included with net-snmp 5.1. It
segfaults when using asynchronous callbacks and GETBULK requests.
Comment 1 Kaj J. Niemi 2003-12-01 19:13:02 EST
Created attachment 96271 [details]
Diff for SNMP.xs preventing segmentation faults while using callbacks
Comment 2 Phil Knirsch 2003-12-10 09:38:00 EST
Looks cool, will include in net-snmp-5.1-3 and later.

Thanks. :-)

Read ya, Phil
Comment 3 Michael J. Slifcak 2004-09-16 00:51:50 EDT
http://sourceforge.net/tracker/index.php?func=detail&aid=1028976&group_id=12694&atid=312694

describes a more complete patch in the upstream code.

Do you (Kay) have a test case that demonstrates the problem
which your patch will fix ?
Comment 4 Kaj J. Niemi 2004-09-16 06:22:53 EDT
Michael,

Your patch looks good. For some reason I have not hit problem in
snmp_getbulk() (the second part of your patch).

Maybe because the problem still gets fixed in __snmp_xs_cb() before
returning to perl? It would be interesting to know. :)

I don't have the snippet isolating the problem anymore, sorry.


Note You need to log in before you can comment on or make changes to this bug.