Bug 1113275 - Need to update /etc/ant.d/apache-ivy
Summary: Need to update /etc/ant.d/apache-ivy
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apache-ivy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Srb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-25 20:11 UTC by Pete MacKinnon
Modified: 2014-06-26 05:38 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-26 05:38:13 UTC


Attachments (Terms of Use)

Description Pete MacKinnon 2014-06-25 20:11:46 UTC
/etc/ant.d/apache-ivy has to contain a valid path string to the ivy jar location.

apache-ivy-2.3.0-13 has this as "ivy" which was the old jar location:
/usr/share/java/ivy.jar

However, -13 installs the jar (and no softlinks) to:
/usr/share/java/apache-ivy/ivy.jar

This causes failures in the ivy builds such as for pig and hive. For example:

ivy-init-antlib:                                                                                                                                                                                                                             
     [echo] Project: hive                                                                                                                                                                                                                    
  [typedef] Could not load definitions from resource org/apache/ivy/ant/antlib.xml. It could not be found.                                                                                                                                   

BUILD FAILED                                                                                                                                                                                                                                 
/home/pmackinn/rpmbuild/BUILD/hive-release-0.12.0/build.xml:246: You need Apache Ivy 2.1 or later from http://ant.apache.org/                                                                                                                
      It could not be loaded from http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.3.0/ivy-2.3.0.jar

Comment 1 Michal Srb 2014-06-26 05:38:13 UTC
Thanks for the bug report. The issue should be fixed in apache-ivy-2.3.0-15.fc21.


Note You need to log in before you can comment on or make changes to this bug.