Bug 111334 - API of Assert.exists() doesn't allow a useful error message
API of Assert.exists() doesn't allow a useful error message
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-02 06:31 EST by Matthew Booth
Modified: 2007-06-17 18:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 18:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2003-12-02 06:31:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031026 Firebird/0.7

Description of problem:
A typo in a DomainObjectTraversal adapters xml file gave me the
following stack trace:

2003-12-02 11:20:22,717 [ main] ERROR util.Assert -
com.arsdigita.persistence.metadata.ObjectType is null
com.arsdigita.util.AssertionError:
com.arsdigita.persistence.metadata.ObjectType is null
        at com.arsdigita.util.Assert.error(Assert.java(Inlined
Compiled Code))
        at com.arsdigita.util.Assert.exists(Assert.java(Compiled Code))
        at
com.arsdigita.domain.DomainObjectTraversal.registerAdapter(DomainObjectTraversal.java:79)
        at
com.arsdigita.domain.DomainObjectTraversal.registerAdapter(DomainObjectTraversal.java:112)


The reason it can't output a useful error message is that there is no
API to Assert.exists() to allow this.

Version-Release number of selected component (if applicable):
Rickshaw

Note You need to log in before you can comment on or make changes to this bug.