Bug 111373 - sd_init_onedisk() waits approximately 100 seconds for passive-mode device to spin up.
sd_init_onedisk() waits approximately 100 seconds for passive-mode device to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-02 13:25 EST by Heather Conway
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version: U3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-20 08:19:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The original 32-bit version of the emc-lun-not -ready.patch is attached. (734 bytes, patch)
2003-12-02 13:27 EST, Heather Conway
no flags Details | Diff

  None (edit)
Description Heather Conway 2003-12-02 13:25:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
FunWebProducts)

Description of problem:
This was already fixed in the 32-bit version of RHEL 2.1.
sd_init_onedisk() waits approximately 100 seconds for each CLARiiON 
passive-mode device to spin up when the device driver is loading.  
Since these passive-mode devices are non-responsive to the
START_STOP SCSI message used to spin up non-removable media, the 
delay is unnecessary.

I would like to request that the RHEL 2.1 AS 64-bit sd.c be changedto 
match the changes made to RHEL 2.1 32-bit?  This was fixed for 32-bit 
RHEL 2.1 - see bugzilla #68883.
QLogic driver v6.04.01 is being used.


Version-Release number of selected component (if applicable):
kernel-source-2.4.18-e.37

How reproducible:
Always

Steps to Reproduce:
Attach to the CLARiiON array that has passive-mode devices and boot 
up your RHEL 2.1 64-bit Linux host.  The host will attempt to spin up 
each individual passive mode device.  For instance, with the 100 
second delay for each passive I/O path, a RHEL 2.1 64-bit 
configuration with 128 SCSI disk devices, 64 of which are passive, 
will incur a 1 hour 46 minute delay on bootup.

Additional info:
Comment 1 Heather Conway 2003-12-02 13:27:03 EST
Created attachment 96297 [details]
The original 32-bit version of the emc-lun-not -ready.patch is attached.
Comment 5 Jason Baron 2003-12-19 10:10:41 EST
included in U3

Note You need to log in before you can comment on or make changes to this bug.