Bug 111380 - gaim often crashes when I cut&paste into messages
gaim often crashes when I cut&paste into messages
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gaim (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-02 14:58 EST by Bryan Che
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 14:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2003-12-02 14:58:58 EST
Description of problem:

Gaim often crashes when I cut and paste stuff into the message window
and then try to send it (over AIM).  It doesn't seem to consistently
crash with any given text, but this when has caused it to crash a
couple times:

+ '[' -z root ']'
+ '[' -n root ']'
++ id -u root
+ CCM_USER_ID=0
+ '[' 0 '!=' 0 ']'
+ '[' 0 == 0 ']'


Version-Release number of selected component (if applicable):

gaim-0.66-3.0.2


How reproducible:

often

Steps to Reproduce:
1. cut&paste text
2. send IM
3.
  
Actual results:

gaim doesn't crash

Expected results:

gaim crashes

Additional info:
Comment 1 Christopher Blizzard 2003-12-02 15:55:00 EST
Can you try this with a more recent gaim, say from rawhide?
Comment 2 Bryan Che 2003-12-02 16:10:57 EST
I wasn't able to try that gaim on my RHEL3 box.  I tried
gaim-0.74-5.i386.rpm but got the error: 
error: Failed dependencies:
        libaspell.so.15 is needed by gaim-0.74-5
        libgtkspell.so.0 is needed by gaim-0.74-5

Comment 3 Christopher Blizzard 2003-12-02 17:28:12 EST
You will probably have to rebuild it on that box to get it to work in
RHEL 3.
Comment 4 Bryan Che 2003-12-03 09:41:25 EST
I downloaded gaim-0.74-5.src.rpm and got a dependency error:      
gtkspell-devel is needed by gaim-0.74-5.  I don't think that package
exists for RHEL3 either.  Where do I get that?
Comment 5 Christopher Blizzard 2003-12-03 11:40:07 EST
I think that you can just remove the BuildRequires: from the spec
file.  I _think_ that gaim will just not build the spellchecking bits.
Comment 6 Warren Togami 2004-03-17 03:23:42 EST
Correct, gtkspell is an optional requirement for gaim building.
http://download.fedora.us/fedora/fedora/1/i386/SRPMS.updates/gaim-0.75-1.3.0.src.rpm

This is the latest FC1 update for gaim.  Please edit the .spec and
remove gtkspell and give the build a try, then let me know how it
goes.  I believe there are known issues with the yahoo protocol,
unless you try the 0.75.99 snapshot from rawhide.  This advice is of
course unsupported and at your own risk for RHEL3, but it should
theoretically solve your problem.
Comment 7 Daniel Reed 2004-05-21 14:20:43 EDT
Please reopen if this is still relevant.

Note You need to log in before you can comment on or make changes to this bug.