Bug 111409 - missing return statement
Summary: missing return statement
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-03 11:25 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.70-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-08 23:57:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-12-03 11:25:46 UTC
Description of problem:
I just tried to compile package usermode-1.69-1 from Fedora.

The compiler said

usermount.c(640): remark #1011: missing return statement at end of
non-void function "create_usermount_window"

The source code is

static gboolean
create_usermount_window()
{
	/* more code */
}

It is not wise to miss out the return statement at the end of
the routine.

Suggest add

	return TRUE;

since FALSE seems to be the error exit.



Version-Release number of selected component (if applicable):
usermode-1.69-1 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nalin Dahyabhai 2003-12-08 23:57:39 UTC
Fixing in 1.70.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.