Bug 111412 - [RFE] fontconfig support
[RFE] fontconfig support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-03 07:01 EST by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 13:10:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fontconfig support patch (19.56 KB, patch)
2003-12-03 07:02 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2003-12-03 07:01:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1)
Gecko/20030303

Description of problem:
To enhance the behavior, supporting fontconfig to get the valid font
list is good idea IMO. it saves the trouble and we no longer need to
describe the font list in Fontmap/CIDFnmap except describing the aliases.
patch will be attached. please review it whether it's worth to apply
for us.

Version-Release number of selected component (if applicable):
Comment 1 Akira TAGOH 2003-12-03 07:02:08 EST
Created attachment 96308 [details]
fontconfig support patch
Comment 2 Miloslav Trmac 2003-12-03 14:18:05 EST
Why is PKG_CHECK_MODULES copied into configure.ac? It should be
added to aclocal.m4 by aclocal.
Comment 3 Akira TAGOH 2003-12-03 22:03:29 EST
Because ghostscript has some trick to build itself and aclocal breaks it.
Comment 4 Akira TAGOH 2003-12-03 22:21:23 EST
Also, attached patch is a bit RH specific to be able to apply it for
us. re-running autotools stuff will also breaks our build. so
basically we don't need the changes of configure.ac, though.
Comment 5 Tim Waugh 2003-12-05 07:53:42 EST
It needs to patch src/unix-gcc.mak rather than Makefile directly,
since we build Makefile after applying the patches.
Comment 6 Tim Waugh 2003-12-05 08:33:16 EST
That was easy -- just needed to edit the filename in the patch.

Next issue: we can't default to spewing debug messages out.
Comment 7 Tim Waugh 2003-12-05 10:07:32 EST
I've commented out these:

DEBUG: FC_OUTLINE mismatch
DEBUG: neither TrueType font nor OpenType font
DEBUG: growing the dictionary: max: %d
DEBUG: psname: %s, file: %s, idx: %d

In one of the functions '.font' seems to be an allowed extension, but
in the other it is not -- is that intentional?
Comment 8 Tim Waugh 2003-12-05 11:30:26 EST
Please take a look at ghostscript-7.07-13, which incorporates your
patch with the modifications I've made.
Comment 9 Akira TAGOH 2003-12-07 19:39:09 EST
assuming .font is symlinked to TrueType font. basically it should be
duplicate. so no problem to always disallow it.

Note You need to log in before you can comment on or make changes to this bug.