Bug 111464 - segfault running 'pear' with heavily modified php.ini; no problem with stock php.ini
segfault running 'pear' with heavily modified php.ini; no problem with stock ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-03 18:23 EST by Jeff MacDonald
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 03:08:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heavily modified php.ini (3.96 KB, text/plain)
2003-12-03 18:24 EST, Jeff MacDonald
no flags Details

  None (edit)
Description Jeff MacDonald 2003-12-03 18:23:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have a heavily modified php.ini installed on a production machine
called 'toast'. when I try to run 'pear help', I get a segfault. when
I install the "stock" php.ini, I don't get a segfault. I am not
certain what option I have changed that causes this, but it shouldn't
segfault.


Version-Release number of selected component (if applicable):
php-4.2.2-17.2

How reproducible:
Always

Steps to Reproduce:
1. pear help
2. segfault
3.
    

Actual Results:  segfault

Expected Results:  help screen


Additional info:
Comment 1 Jeff MacDonald 2003-12-03 18:24:15 EST
Created attachment 96328 [details]
heavily modified php.ini
Comment 2 Jeff MacDonald 2003-12-03 18:32:15 EST
for some reason, I had two copies of php installed, so I nuked them
both, and installed php-4.2.2-17.2 using up2date. I get a segfault
every time I run pear.

I went to the pear website, and installed the latest version of pear
(1.3b2), and I still get the segfault.

note that I am using php in production on toast, and I don't have any
problems, so this is somehow pear specific.
Comment 3 Joe Orton 2003-12-04 04:27:42 EST
The problem is that "pear help" uses fopen('php://stderr', 'w'), which
fails when allow_url_fopen = Off in 4.2, and then goes on to segfault
when an invalid file handle is passed to fputs.

This appears to be fixed in 4.3.
Comment 4 Jeff MacDonald 2003-12-04 20:07:12 EST
yay! :).. that seems to have fixed it.. I also needed to allow for
register_argc_argv, but the problem went away when I updated a couple
of settings. thanks for the assistance.
Comment 5 Joe Orton 2003-12-05 03:08:18 EST
Thanks.  Closing this, it's fixed in Fedora Core 1 (and RHEL3).

Note You need to log in before you can comment on or make changes to this bug.