Bug 111491 - rhn_check traceback...
rhn_check traceback...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhnlib (Show other bugs)
3.0
All Linux
high Severity high
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 10:17 EST by Johnray Fuller
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 00:56:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2003-12-04 10:17:36 EST
I freshly installed a system, scheduled some packages to be installed
and ran rhn_check update_packages. This is the result:

packages.update ([['IBMJava2-JRE', '1.4.1', '8', '1'],
['IBMJava2-SDK', '1.4.1', '9', '1'], ['ipvsadm', '1.21', '9.ipvs108',
''], ['jrockit-j2se', '8.1.1.1', '2', ''], ['kernel-BOOT', '2.4.21',
'4.0.1.EL', ''], ['kernel-debuginfo', '2.4.21', '4.0.1.EL', ''],
['kernel-doc', '2.4.21', '4.0.1.EL', ''], ['kernel-hugemem', '2.4.21',
'4.0.1.EL', ''], ['kernel-hugemem-unsupported', '2.4.21', '4.0.1.EL',
''], ['kernel-smp', '2.4.21', '4.0.1.EL', ''],
['kernel-smp-unsupported', '2.4.21', '4.0.1.EL', ''],
['kernel-unsupported', '2.4.21', '4.0.1.EL', ''], ['mysql-server',
'3.23.58', '1', ''], ['piranha', '0.7.6', '1', ''], ['quagga-contrib',
'0.96.2', '8.3E', ''], ['quagga-devel', '0.96.2', '8.3E', ''],
['redhat-config-cluster', '1.0.0', '5', ''], ['rh-cs-en', '3', '1',
''], ['rh-glossary-en', '1.1', '2', ''], ['rh-postgresql-pl', '7.3.4',
'8', ''], ['rh-postgresql-server', '7.3.4', '8', ''],
['rh-postgresql-test', '7.3.4', '8', ''], ['rhdb-admin', '2.0', '7',
''], ['rhdb-cc', '1.0_Beta', '2', ''], ['rhdb-docs', '3.0', '5', ''],
['rhdb-explain', '2.0', '7', ''], ['rhel-as-en', '3', '1', ''],
['rhel-binutils-en', '3', '1', ''], ['rhel-cpp-en', '3', '1', ''],
['rhel-devtools-en', '3', '1', ''], ['rhel-gcc-en', '3', '1', ''],
['rhel-gdb-en', '3', '1', ''], ['rhel-ig-ppc-multi-en', '3', '1', ''],
['rhel-ig-s390-multi-en', '3', '2', ''], ['rhel-ig-x8664-multi-en',
'3', '1', ''], ['rhel-isa-en', '3', '1', ''], ['rhel-ld-en', '3', '1',
''], ['rhel-rg-en', '3', '1', ''], ['rhel-sag-en', '3', '2', ''],
['rhel-sg-en', '3', '1', '']],)
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 332, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 209, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 164, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 92, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 345, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 187, in _catchErrors
    ret = apply(method, args)
  File "/usr/share/rhn/actions/packages.py", line 384, in batchRun
    actionPkgs = pkgList)
  File "wrapper.py", line 1028, in batchRun
  File "up2dateBatch.py", line 57, in run
  File "up2dateBatch.py", line 99, in __findPackagesToUpdate
  File "packageList.py", line 519, in getPackagesToInstall
  File "packageList.py", line 548, in __skipPackages
  File "packageList.py", line 569, in __skipFiles
  File "packageList.py", line 608, in buildHeaderList
  File "headers.py", line 44, in __getitem__
  File "headers.py", line 49, in __retrievePackage
  File "rpcServer.py", line 111, in doCall
  File "repoDirector.py", line 37, in getHeader
  File "rpmSource.py", line 210, in getHeader
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 84, in getHeader
    fd = self.s.getPackageHeader(channel, filename)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 555, in
__call__
    result = self._send(self._name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 302, in
_request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 167,
in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 688,
in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 701, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 723, in _send_request
    self.endheaders()
  File "/usr/lib/python2.2/httplib.py", line 695, in endheaders
    self._send_output()
  File "/usr/lib/python2.2/httplib.py", line 581, in _send_output
    self.send(msg)
  File "/usr/lib/python2.2/httplib.py", line 560, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 191, in write
    sent = self._connection.send(data)
SSL.Error: [('SSL routines', 'SSL3_READ_BYTES', 'tlsv1 alert decrypt
error'), ('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]

[root@homocorrectus root]# rpm -qf /usr/sbin/rhn_check
up2date-4.0.1-1

The packages were not installed.

Let em knwo if you need more info.

Johnray
Comment 1 Johnray Fuller 2003-12-04 10:25:21 EST
I since there was an SSL error, I checked to see if a firewall was
active on the box and it was, so I fixed it.

Sorry for the misqueue :-(

Johnray
Comment 2 Johnray Fuller 2003-12-04 10:46:37 EST
It did it again.

Here is what was printed to standard out:

 rhn_check update_packages
packages.update ([['IBMJava2-JRE', '1.4.1', '8', '1'],
['IBMJava2-SDK', '1.4.1', '9', '1'], ['ipvsadm', '1.21', '9.ipvs108',
''], ['jrockit-j2se', '8.1.1.1', '2', ''], ['kernel-BOOT', '2.4.21',
'4.0.1.EL', ''], ['kernel-debuginfo', '2.4.21', '4.0.1.EL', ''],
['kernel-doc', '2.4.21', '4.0.1.EL', ''], ['kernel-hugemem', '2.4.21',
'4.0.1.EL', ''], ['kernel-hugemem-unsupported', '2.4.21', '4.0.1.EL',
''], ['kernel-smp', '2.4.21', '4.0.1.EL', ''],
['kernel-smp-unsupported', '2.4.21', '4.0.1.EL', ''],
['kernel-unsupported', '2.4.21', '4.0.1.EL', ''], ['mysql-server',
'3.23.58', '1', ''], ['piranha', '0.7.6', '1', ''], ['quagga-contrib',
'0.96.2', '8.3E', ''], ['quagga-devel', '0.96.2', '8.3E', ''],
['redhat-config-cluster', '1.0.0', '5', ''], ['rh-cs-en', '3', '1',
''], ['rh-glossary-en', '1.1', '2', ''], ['rh-postgresql-pl', '7.3.4',
'8', ''], ['rh-postgresql-server', '7.3.4', '8', ''],
['rh-postgresql-test', '7.3.4', '8', ''], ['rhdb-admin', '2.0', '7',
''], ['rhdb-cc', '1.0_Beta', '2', ''], ['rhdb-docs', '3.0', '5', ''],
['rhdb-explain', '2.0', '7', ''], ['rhel-as-en', '3', '1', ''],
['rhel-binutils-en', '3', '1', ''], ['rhel-cpp-en', '3', '1', ''],
['rhel-devtools-en', '3', '1', ''], ['rhel-gcc-en', '3', '1', ''],
['rhel-gdb-en', '3', '1', ''], ['rhel-ig-ppc-multi-en', '3', '1', ''],
['rhel-ig-s390-multi-en', '3', '2', ''], ['rhel-ig-x8664-multi-en',
'3', '1', ''], ['rhel-isa-en', '3', '1', ''], ['rhel-ld-en', '3', '1',
''], ['rhel-rg-en', '3', '1', ''], ['rhel-sag-en', '3', '2', ''],
['rhel-sg-en', '3', '1', '']],)
 
Name                                    Version        Rel
----------------------------------------------------------
IBMJava2-JRE                            1.4.1          8             
     i386
IBMJava2-SDK                            1.4.1          9             
     i386
ipvsadm                                 1.21           9.ipvs108     
     i386
jrockit-j2se                            8.1.1.1        2             
     i386
kernel-BOOT                             2.4.21         4.0.1.EL      
     i386
kernel-debuginfo                        2.4.21         4.0.1.EL      
     i686
kernel-doc                              2.4.21         4.0.1.EL      
     i386
kernel-hugemem                          2.4.21         4.0.1.EL      
     i686
kernel-hugemem-unsupported              2.4.21         4.0.1.EL      
     i686
kernel-smp                              2.4.21         4.0.1.EL      
     i686
kernel-smp-unsupported                  2.4.21         4.0.1.EL      
     i686
kernel-unsupported                      2.4.21         4.0.1.EL      
     i686
mysql-server                            3.23.58        1             
     i386
piranha                                 0.7.6          1             
     i386
quagga-contrib                          0.96.2         8.3E          
     i386
quagga-devel                            0.96.2         8.3E          
     i386
redhat-config-cluster                   1.0.0          5             
     noarch
rh-cs-en                                3              1             
     noarch
rh-glossary-en                          1.1            2             
     noarch
rh-postgresql-pl                        7.3.4          8             
     i386
rh-postgresql-server                    7.3.4          8             
     i386
rh-postgresql-test                      7.3.4          8             
     i386
rhdb-admin                              2.0            7             
     noarch
rhdb-cc                                 1.0_Beta       2             
     noarch
rhdb-docs                               3.0            5             
     noarch
rhdb-explain                            2.0            7             
     noarch
rhel-as-en                              3              1             
     noarch
rhel-binutils-en                        3              1             
     noarch
rhel-cpp-en                             3              1             
     noarch
rhel-devtools-en                        3              1             
     noarch
rhel-gcc-en                             3              1             
     noarch
rhel-gdb-en                             3              1             
     noarch
rhel-ig-ppc-multi-en                    3              1             
     noarch
rhel-ig-s390-multi-en                   3              2             
     noarch
rhel-ig-x8664-multi-en                  3              1             
     noarch
rhel-isa-en                             3              1             
     noarch
rhel-ld-en                              3              1             
     noarch
rhel-rg-en                              3              1             
     noarch
rhel-sag-en                             3              2             
     noarch
rhel-sg-en                              3              1             
     noarch
 
IBMJava2-JRE-1.4.1-8.i386.r ########################## Done.
IBMJava2-SDK-1.4.1-9.i386.r ########################## Done.
ipvsadm-1.21-9.ipvs108.i386 ########################## Done.
jrockit-j2se-8.1.1.1-2.i386 ########################## Done.
kernel-BOOT-2.4.21-4.0.1.EL ########################## Done.
kernel-debuginfo-2.4.21-4.0 ########################## Done.
kernel-doc-2.4.21-4.0.1.EL. ########################## Done.
kernel-hugemem-2.4.21-4.0.1 ########################## Done.
kernel-hugemem-unsupported- ########################## Done.
kernel-smp-2.4.21-4.0.1.EL. ########################## Done.
kernel-smp-unsupported-2.4. ########################## Done.
kernel-unsupported-2.4.21-4 ########################## Done.
mysql-server-3.23.58-1.i386
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 332, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 209, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 164, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 92, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 345, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 187, in _catchErrors
    ret = apply(method, args)
  File "/usr/share/rhn/actions/packages.py", line 384, in batchRun
    actionPkgs = pkgList)
  File "wrapper.py", line 1028, in batchRun
  File "up2dateBatch.py", line 79, in run
  File "up2dateBatch.py", line 147, in __getPackages
  File "up2date.py", line 176, in getPackage
  File "rpcServer.py", line 111, in doCall
  File "repoDirector.py", line 41, in getPackage
  File "rpmSource.py", line 183, in getPackage
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 133, in getPackage
    fd = self.s.getPackage(channel, filename)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 555, in
__call__
    result = self._send(self._name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 302, in
_request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 167,
in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 688,
in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 701, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 723, in _send_request
    self.endheaders()
  File "/usr/lib/python2.2/httplib.py", line 695, in endheaders
    self._send_output()
  File "/usr/lib/python2.2/httplib.py", line 581, in _send_output
    self.send(msg)
  File "/usr/lib/python2.2/httplib.py", line 560, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 191, in write
    sent = self._connection.send(data)
SSL.Error: [('SSL routines', 'SSL3_READ_BYTES', 'tlsv1 alert decrypt
error'), ('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]


This is what was in /var/log/up2date:

[Thu Dec  4 10:25:08 2003] up2date updating login info
[Thu Dec  4 10:25:08 2003] up2date logging into up2date server
[Thu Dec  4 10:25:09 2003] up2date successfully retrieved
authentication token from up2date server
[Thu Dec  4 10:25:09 2003] up2date availablePackageList from network
[Thu Dec  4 10:26:24 2003] up2date updating login info
[Thu Dec  4 10:26:24 2003] up2date logging into up2date server
[Thu Dec  4 10:26:25 2003] up2date successfully retrieved
authentication token from up2date server
[Thu Dec  4 10:26:25 2003] up2date availablePackageList from network
 
service iptables status
Table: filter
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
 
Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
 
Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

I am running it again and it seems to get further along each time...

Odd.

Johnray
Comment 3 Adrian Likins 2003-12-05 13:34:47 EST
SSL.Error: [('SSL routines', 'SSL3_READ_BYTES', 'tlsv1 alert decrypt
error'), ('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]

sounds like a ssl errors, not sure what they mean, cc'ing misa
to see if he knows. 

my first impression would be that the 'tlsv1 alert decrypt
error' is indicating failures to do the magic crpyto bits. The
math to do crptyo failing sometimes indicates ram/cpu problems
(aka, random bit noise...). But thats an uneducated guess.
Comment 4 Mihai Ibanescu 2004-10-07 00:56:25 EDT
Johnray, please reopen this if it still happens. I haven't seen it
anywhere else.

Note You need to log in before you can comment on or make changes to this bug.