Bug 111504 - [PATCH] rhdb startup script does not pay attention to PGOPTS variable / file
Summary: [PATCH] rhdb startup script does not pay attention to PGOPTS variable / file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postgresql   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 121754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-04 17:52 UTC by John Berninger
Modified: 2013-07-03 02:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 22:59:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch for this bug (743 bytes, patch)
2003-12-04 17:54 UTC, John Berninger
no flags Details | Diff
actual patch - first one had debugging information in the patch - sorry (593 bytes, patch)
2003-12-04 17:55 UTC, John Berninger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:307 normal SHIPPED_LIVE Updated rh-postgresql packages 2004-08-02 04:00:00 UTC

Description John Berninger 2003-12-04 17:52:33 UTC
Description of problem:
service rhdb start does not use options created in
/etc/sysconfig/pgsql/rhdb as it should

Version-Release number of selected component (if applicable):
rh-postgresql-server-7.3.4-8

How reproducible:
always

Steps to Reproduce:
1.echo "-i" > /etc/sysconfig/pgsql/rhdb
2.service rhdb start
3.ps -ef | grep postmaster
  
Actual results:
postmaster running without -i option

Expected results:
postmaster running with -i option

Additional info:

Comment 1 John Berninger 2003-12-04 17:54:18 UTC
Created attachment 96345 [details]
proposed patch for this bug

Comment 2 John Berninger 2003-12-04 17:55:40 UTC
Created attachment 96346 [details]
actual patch - first one had debugging information in the patch - sorry

Comment 3 David Jee 2003-12-05 21:05:01 UTC
Currently, there is no active support for the rh-postgresql set of
packages in RHEL3.  So as it stands, there will be no errata. 
However, the same set of RPMs have been incorporated into Fedora Core
1, under the name of postgresql-*.  I can include your patch into
Fedora's postgresql instead.  Would that work for you?

Comment 4 John Berninger 2003-12-05 21:33:49 UTC
For me personally, yes...  but GSS is going to be expected to support
this, and this may not work for Thomas, especially considering the
issues we've had recently about the server packages not being in the
original RHEL 3 release to begin with.  Customers are not going to be
too happy, but I'll leave the final decision to others higher up in
the food chain.

Comment 5 Tom Lane 2004-03-10 21:57:50 UTC
I have patched this for Fedora Core 2.  If I get a window of
opportunity I will sneak it into the RHEL3 stream as well, but I won't
roll the RHEL package just for this.  (As a rule, you'd be better off
setting options from postgresql.conf than on the postmaster command
line anyway.)

Comment 6 Tom Lane 2004-04-28 13:55:31 UTC
*** Bug 121754 has been marked as a duplicate of this bug. ***

Comment 7 Tom Lane 2004-06-23 22:59:12 UTC
Repaired in rh-postgresql 7.3.6-3.

Comment 9 Tom Lane 2004-09-22 23:34:04 UTC
initdb takes care of copying postgresql.conf.sample to the active file
($PGDATA/postgresql.conf).  We cannot do what you suggest without
making wholesale revisions to the way the upstream package works. 
Whether or not it would be a good idea in a green-field situation, I
don't think it's wise to make RH's version of postgres work
differently from everyone else's.


Note You need to log in before you can comment on or make changes to this bug.