Bug 111506 - TwinMos mobile disk isn't properly detected
Summary: TwinMos mobile disk isn't properly detected
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug   
(Show other bugs)
Version: 1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-04 18:20 UTC by Christian Schaller
Modified: 2014-03-17 02:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 17:32:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hotplug-twinmos.patch (1.35 KB, patch)
2004-07-02 11:49 UTC, Bastien Nocera
no flags Details | Diff

Description Christian Schaller 2003-12-04 18:20:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
In order to get hotplug to correctly detect my Twinmos USB penndrive I
had to add the following line to usb.distmap:
 usb-storage          0x000f 0x0ea0   0x06803    0x0200       0x0200 
     0x00        0x00            0x00            0x00            0x00
           0x00         0x00000000

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
n/a 

Additional info:

Comment 1 Bastien Nocera 2003-12-04 18:22:35 UTC
This is because the pendrive doesn't show up as mass storage class but
as "Vendor Specific Class".

Comment 2 Christian Schaller 2004-06-10 07:57:51 UTC
Bill you commited the 'other half' of this fix to magicdev before 
Fedora 2, but this part still needs merging for these penndrives to 
autodetect properly under Red Hat/Fedora :)

Comment 3 Christian Schaller 2004-06-17 13:04:42 UTC
Would I make it easier/speed up inclusion if I provided a patch?

Comment 4 Bill Nottingham 2004-06-28 20:35:42 UTC
Please.

Comment 5 Bastien Nocera 2004-07-02 11:49:29 UTC
Created attachment 101594 [details]
hotplug-twinmos.patch

Hmm, Bill committed the patch to updfstab, not magicdev ;)

Here's the one-liner (a long one, I must admit).

Comment 6 Bill Nottingham 2004-07-02 17:32:46 UTC
Added in -4.


Note You need to log in before you can comment on or make changes to this bug.