Bug 111532 - undefined source code
Summary: undefined source code
Status: CLOSED DUPLICATE of bug 106314
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-04 22:11 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-12-04 22:11:42 UTC
Description of problem:
I just tried to compile package xsane-0.91-1 from Fedora.

The compiler said

xsane-preview.c:6331: warning: operation on `image_data_rawp' may be
undefined

The source code is

	level = ((*image_data_rawp++) 
				+ (*image_data_rawp++) 
				+ (*image_data_rawp++)) / 3;

This is undefined C code. The following code is legal, and
perhaps what was intended.

	level = ((image_data_rawp[ 0]) 
				+ (image_data_rawp[ 1]) 
				+ (image_data_rawp[ 2])) / 3;
	image_data_rawp += 3;



Version-Release number of selected component (if applicable):
xsane-0.91-1 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2003-12-05 12:41:02 UTC
You already reported this -- and I already fixed it.

*** This bug has been marked as a duplicate of 106314 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.