This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 111553 - logrotate: mailfirst and delaycompress do not work together
logrotate: mailfirst and delaycompress do not work together
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-05 06:20 EST by Ales Ledvinka
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 16:11:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Ledvinka 2003-12-05 06:20:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624

Description of problem:
using mailfirst and delaycompress nothing is mailed.
an attemtpt to mail nonexistent file is made. (with compressed extension)


Version-Release number of selected component (if applicable):
logrotate-3.6.5-2

How reproducible:
Always

Steps to Reproduce:
0.cat apachewebalizer
/usr/local/apache2/logs/access_log {
        compress
        create 644 root root
#       copytruncate
        daily
        delaycompress
        ifempty
        mail root@localhost
        mailfirst
        nomissingok
        noolddir

        prerotate
        endscript

        postrotate
        endscript

        rotate 9
        size 1500M
        sharedscripts
        start 0
}
1.logrotate -f -s /tmp/stav /etc/logrotate.d/apachewebalizer
2.
3.


Actual Results:  logrotate -f -s /tmp/stav
/etc/logrotate.d/apachewebalizer
sh: line 1: /usr/local/apache2/logs/access_log.0.gz: No such file or
directory
Failed to mail /usr/local/apache2/logs/access_log.0.gz to root@localhost!


Expected Results:  probably best: mail access_log.1.gz


Additional info:
Comment 1 Elliot Lee 2003-12-17 16:11:26 EST
I'm pretty sure I've seen this bug before and that it has been fixed
since 8.0. Please upgrade...

Note You need to log in before you can comment on or make changes to this bug.