Bug 111576 - system locks attempting to sync USB Palm/Visor devices
system locks attempting to sync USB Palm/Visor devices
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-05 12:34 EST by Kevin Otte
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 21:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Otte 2003-12-05 12:34:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I am attempting to configure a Handspring Visor USB to work with the
GNOME Pilot tools.  Anytime a HotSync operation is attempted, the
system hard locks (no keyboard, mouse, or network).

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.10-1

How reproducible:
Always

Steps to Reproduce:
1. Add Pilot Applet to panel
2. Follow wizard, adding USB device on /dev/usb/ttyUSB1
3. Wizard will state "About to retrieve info from pilot... press
HotSync button now".
4. Within a few seconds of HotSync button being pressed, system will
hard lock.
    

Actual Results:  System hard locks, only recovery method is power cycle.

Expected Results:  GNOME Pilot should have retrieved information from
the pilot and continued with the wizard.

Additional info:

I booted the machine into console mode and started a HotSync from the
device.  The kernel is finding the device and loading the appropriate
modules:

usb.c: USB device 2 (vend/prod 0x82d/0x100) is not claimed by any
active driver.usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
usbserial.c: USB Serial support registered for Handspring Visor / Treo
/ Palm 4.0 / Cli 4.x
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x converter
detected
visor.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x: Number of ports: 2
visor.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x: port 1, is for
Generic use and is bound to ttyUSB0
visor.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x: port 2, is for
HotSync use and is bound to ttyUSB1
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x converter
now attached to ttyUSB0 (or usb/tts/0 for devfs)
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Cli 4.x converter
now attached to ttyUSB1 (or usb/tts/1 for devfs)
usbserial.c: USB Serial support registered for Sony Cli 3.5
visor.c: USB HandSpring Visor, Palm m50x, Treo, Sony Cli driver v1.7
Comment 1 Jeremy Katz 2003-12-10 02:02:49 EST
Do you get flashing keyboard LEDs?
Comment 2 Pete Zaitcev 2003-12-11 15:44:31 EST
Looks like the visor oops which we saw recently.

Kevin, please answer Jeremy's question about flashing LEDs.

Also please test these:
ftp://people.redhat.com/zaitcev/tmp/
 kernel*-2.4.22-1.2130.2.3.nptl*.rpm   <---- select one you like.
Comment 3 Kevin Otte 2003-12-11 16:26:33 EST
After further inspection, we find that this problem only occurs on the
IBM ThinkPad X31 when using the on-board USB ports.  When using the
USB ports on the docking slice, the operation completes successfully.
 Also, the operation completes successfully on the IBM ThinkPad T30.

When the system freezes, the Caps Lock LED is blinking.
Comment 4 Kevin Otte 2003-12-12 10:22:25 EST
We installed kernel-2.4.22-1.2130.2.3.nptl.i686 and the USB problem
did not occur, however the network was rendered useless.
Comment 5 Pete Zaitcev 2004-01-17 11:47:53 EST
Did the 2.4.22-1.2140 fix the problem?
Comment 6 Kevin Otte 2004-03-25 14:53:35 EST
Sorry for the lag on this.  I would like to revisit this issue.  We
just re-ran this procedure with 2.4.21-9.0.1.EL and it is still
failing.  I mentioned in a previous report that the
kernel-2.4.22-1.2130.2.3.nptl.i686 you provided for testing did fix
the problem, but it created another problem.
Comment 7 Pete Zaitcev 2004-04-06 16:58:34 EDT
Kevin, please try a kernel from this location:
 ftp://people.redhat.com/zaitcev/us3/
This is a honest to goodness RHEL 3 kernel branch, so everything
should work now.
Comment 8 Kevin Otte 2004-04-08 12:11:31 EDT
That did it!  Wizard completes successfully.

$ uname -r
2.4.21-12.usbserial3.1.EL
Comment 9 Suzanne Hillman 2004-05-13 13:57:02 EDT
Closing, as per comment #8.
Comment 10 Kevin Otte 2004-06-16 12:44:01 EDT
We are now seeing these same symptoms on our users machines with the
Visor devices and Evolution/gpilotd, but now only intermittently. 
This behaviour is now being seen on both the X31 and T41 ThinkPads.
Comment 11 Pete Zaitcev 2004-10-04 21:56:13 EDT
It's imperative to capture the oops (== flashing LEDs). Either a
serial console or netdump would do. I'm not needinfo-ing the bug
for now, but yes that information is required.
Comment 12 Ernie Petrides 2005-10-05 21:38:06 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.