Bug 111621 - OpenOffice.org's Calc extremely slow at charts
Summary: OpenOffice.org's Calc extremely slow at charts
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 2
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-06 18:53 UTC by Carlos Rodrigues
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 01:04:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extremely slow chart (50.70 KB, application/octet-stream)
2004-03-09 00:19 UTC, Carlos Rodrigues
no flags Details

Description Carlos Rodrigues 2003-12-06 18:53:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031117

Description of problem:
I'm trying plot a graphic (line chart) of the values in a column
(~3000 lines) and it is extremely slow (emphasis on the "extremely"),
both at the initial creation of the chart and from then on at making
changes to it. I tried to do the same in gnumeric and it is almost
instantaneous.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. put 3000 values on a column
2. select that column
3. create a line chart from those values
    

Additional info:
My machine is an Athlon 2400+ with 512Mb of RAM.

Comment 1 Carlos Rodrigues 2003-12-08 17:54:12 UTC
An update to this: I tried to do a line chart of only 100 lines and it
takes 5 seconds to create and 1-2 seconds to resize the chart,
meanwhile   openoffice stops respondig without even redrawing the
window (consuming 100% CPU).

Comment 2 Carlos Rodrigues 2003-12-08 18:44:00 UTC
Another thing: hiding the axis descriptions takes away all the slowness.

Comment 3 Dan Williams 2004-03-08 03:42:53 UTC
Could you attach a sample document?

Comment 4 Carlos Rodrigues 2004-03-09 00:19:33 UTC
Created attachment 98389 [details]
Extremely slow chart

This file has a chart generated from the second column of the spreadsheet. try
to resize or otherwise change the chart to see what I mean by slow. If you hide
the X axis labels the slowness is no more (it seems to be writing a label for
every value...!).

Comment 5 Carlos Rodrigues 2004-05-08 21:47:50 UTC
Just FYI, I just tried the version of OpenOffice.org that comes with
Knoppix 3.4, which is OpenOffice.org 1.1.1, and the problem is there
also, so this still isn't fixed in 1.1.1.

Comment 6 Carlos Rodrigues 2004-07-09 18:32:48 UTC
Still present in OpenOffice that comes with Fedora 2.

Comment 7 Caolan McNamara 2004-11-06 01:02:23 UTC
Its wo

Comment 8 Caolan McNamara 2004-11-06 01:04:39 UTC
I can see it alright, it's also still in the up and coming 2.0 series
(1.9.58). I've logged an upstream bug for this. Lets see what the OOo
chart developers think about it.

Comment 9 Caolan McNamara 2004-11-06 01:05:02 UTC
http://qa.openoffice.org/issues/show_bug.cgi?id=36773


Note You need to log in before you can comment on or make changes to this bug.