Bug 111623 - Rawhide openoffice.org-1.1.0-8 build failure on FC1 due to missing file "regcomp"
Rawhide openoffice.org-1.1.0-8 build failure on FC1 due to missing file "regc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-06 14:15 EST by Keith G. Robertson-Turner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-26 00:38:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith G. Robertson-Turner 2003-12-06 14:15:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.22  [en]

Description of problem:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
 
PACKAGE:
openoffice.org-1.1.0-8.src.rpm
 
SOURCE:
http://download.fedora.redhat.
com/pub/fedora/linux/core/development/SRPMS/
 
MD5SUM:
9b3b2b2c89f8fe700137b253ad872a03
 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)
 
iD8DBQE/0imJ2XoLj+pGfn8RAnA1AJ43ua9bfpv5mdgoAOu7QHnXsSnh8QCfeJ4L
/XKiqUUcs9ms4PcHNdx/YN0=
=8Xf9
-----END PGP SIGNATURE-----

BUILD ENVIRONMENT:
Fedora Core release 1 (Yarrow)
Linux 2.4.22-1.2129.nptl

BUILD REQUIRES (results):
pam-devel-0.77-15
perl-5.8.1-92
sed-4.0.8-1
tcsh-6.12-5
zip-2.3-18
autoconf-2.57-3
flex-2.5.4a-30
unzip-5.50-35
XFree86-devel-4.3.0-42
XFree86-libs-4.3.0-42
bzip2-1.0.2-10
db4-devel-4.1.25-14
bison-1.875-5
findutils-4.1.7-17
make-3.79.1-18
tar-1.13.25-12
freetype-devel-2.1.4-5
gcc-3.3.2-1
gcc-c++-3.3.2-1
libstdc++-devel-3.3.2-1
gtk2-devel-2.2.4-5.1
libart_lgpl-2.3.16-1
libart_lgpl-devel-2.3.16-1
libxslt-1.0.33-2
mozilla-devel-1.5-1
mozilla-nspr-devel-1.5-1
mozilla-1.5-1
redhat-menus-0.40-1

ERRORS:
cannot stat `solver/645/unxlngi4.pro/bin/regcomp': No such file or 
directory



Version-Release number of selected component (if applicable):
1.1.0-8

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild openoffice.org-1.1.0-8.src.rpm

Actual Results:  Build fails

Expected Results:  Successful build

Additional info:

...
dmake has been successfully built
+ '[' 1 -gt 2 ']'
+ '[' 1 -gt 1 ']'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.79660
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd oo_1.1_src
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /var/tmp/openoffice.org-1.1.0-root
+ mkdir -p /var/tmp/openoffice.org-1.1.0-root/usr/lib/openoffice
+ RESPONSE_FILE=/usr/src/redhat/BUILD/oo_1.1_src/rsfile.ins
+ cd ./instsetoo/unxlngi4.pro/01/normal/
/var/tmp/rpm-tmp.79660: line 32: cd: ./instsetoo/unxlngi4.
pro/01/normal/: No such file or directory
+ cp -f solver/645/unxlngi4.pro/bin/regcomp /var/tmp/openoffice.
org-1.1.0-root/usr/lib/openoffice/program
cp: cannot stat `solver/645/unxlngi4.pro/bin/regcomp': No such file 
or directoryerror: Bad exit status from /var/tmp/rpm-tmp.79660 (%
install)
Comment 1 Dan Williams 2003-12-06 16:43:16 EST
Hmm, looking at it, I think made a mistake when trying to get multi-processor builds 
working successfully.  So, I think single-processor computers don't even execute the 
build step.  Sorry about that, I'm building 1.1.0-9 right now to fix that.

If you'd like to fix it, just take the "if [ $RPM_BUILD_NCPUS -gt 1 ]; then" and change it 
to -gte instead (for greater-than-or-equal-to).

Dan
Comment 2 Keith G. Robertson-Turner 2003-12-06 21:04:56 EST
Nope, same error, sorry.

/usr/bin/getconf _NPROCESSORS_ONLN does return 1

Enters bootstrap, all ok except for:
checking for _doprnt... no
checking for settz... no

make all-recursive, all ok until:
sysintf.o(.text+0x5f6): In function `Get_temp':
: warning: the use of `tempnam' is dangerous, better use `mkstemp'
(non fatal warning), then:

dmake has been successfully built
+ '[' 1 -gt 2 ']'
+ '[' 1 -gte 1 ']'
/var/tmp/rpm-tmp.75494: line 54: [: -gte: binary operator expected
(Arguments are being typed as stings.)

Looks like "/usr/bin/getconf _NPROCESSORS_ONLN" returns "1" as a 
string, not a number.
Comment 3 Keith G. Robertson-Turner 2003-12-06 21:12:00 EST
Strange ... this works?

#!/bin/bash
RPM_BUILD_NCPUS=$(/usr/bin/getconf _NPROCESSORS_ONLN)
if [ $RPM_BUILD_NCPUS -eq 1 ]
then
echo "it worked"
else
echo "bah!"
fi
exit 0
Comment 4 Keith G. Robertson-Turner 2003-12-06 21:18:37 EST
Oops.

Advanced Bash-Scripting Guide: Chapter 7. Tests:

'-ge

is greater than or equal to

if [ "$a" -ge "$b" ]'
Comment 5 Dan Williams 2003-12-07 22:31:08 EST
My bad.  Sorry.  Does -ge work then?
Comment 6 Dan Williams 2003-12-07 22:32:16 EST
BTW, 1.1.0-9 completely does away with that check, and should simply execute one 
build statement for single-processor boxes.  I'll check on a single CPU box tomorrow 
morning.
Comment 7 Keith G. Robertson-Turner 2003-12-08 01:56:28 EST
Re: Comment #5.

Yep, builds fine (a marathon 12 hour build!)
No errors, no problem.

All I need now is a th_en_GB.dat (British Thesaurus), but that's a
comment for upstream, I guess.

I'll postpone downloading 1.1.0-9, since 1.1.0-8 WorksForMe®.
Comment 8 Dan Williams 2003-12-26 00:38:08 EST
In that case, closing.

Note You need to log in before you can comment on or make changes to this bug.