Bug 111639 - kudzu assignes ethernet and ISDN card to eth0
Summary: kudzu assignes ethernet and ISDN card to eth0
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-07 14:00 UTC by Stephen Reindl
Modified: 2014-03-17 02:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 05:26:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Reindl 2003-12-07 14:00:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.1)
Gecko/20031114

Description of problem:
When running kudzu on my system, both the ethernet card and the ISDN
card (an AVM PCI passive card) are assigned both to eth0.

Version-Release number of selected component (if applicable):
1.1.36-1

How reproducible:
Always

Steps to Reproduce:
1. run kudzu


Actual Results:  [root@yedi root]# kudzu --class NETWORK --probe
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: ne2k-pci
desc: "Realtek|RTL-8029(AS)"
network.hwaddr: 52:54:AB:DD:27:59
vendorId: 10ec
deviceId: 8029
subVendorId: 10ec
subDeviceId: 8029
pciType: 1
pcibus:  0
pcidev:  8
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: hisax
desc: "AVM Audiovisuelles|A1 ISDN [Fritz]"
vendorId: 1244
deviceId: 0a00
subVendorId: 1244
subDeviceId: 0a00
pciType: 1
pcibus:  0
pcidev:  9
pcifn:  0


Expected Results:  [root@yedi root]# kudzu --class NETWORK --probe
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: ne2k-pci
desc: "Realtek|RTL-8029(AS)"
network.hwaddr: 52:54:AB:DD:27:59
vendorId: 10ec
deviceId: 8029
subVendorId: 10ec
subDeviceId: 8029
pciType: 1
pcibus:  0
pcidev:  8
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: hisax
desc: "AVM Audiovisuelles|A1 ISDN [Fritz]"
vendorId: 1244
deviceId: 0a00
subVendorId: 1244
subDeviceId: 0a00
pciType: 1
pcibus:  0
pcidev:  9
pcifn:  0


Additional info:

Either the network card or the ISDN card should have been assigned to eth1

Comment 1 Bill Nottingham 2004-02-04 06:36:42 UTC
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.

Comment 2 Stephen Reindl 2004-02-04 12:11:45 UTC
Unfortunally I'm not using fedore any more because of customer 
requests to use another distribution. Maybe there's somebody outside 
who has as isdn and a network card ... :-)

Comment 3 Panu Matilainen 2004-03-24 12:19:12 UTC
I'm seeing this as well (different hw though), kudzu version is
1.1.36.1. The curious thing is that the aliases get numbered correctly
if I run kudzu -p as a normal user and fails as root:
[pmatilai@localhost pmatilai]$ kudzu -s -p|grep eth
device: eth0
device: eth1
[pmatilai@localhost pmatilai]$ su
Password:
[root@localhost pmatilai]# kudzu -s -p|grep eth
device: eth0
device: eth0

I think I saw some mention of ethtool support (or lack of thereof)
having something to do with a similar case in another bug - if that's
the case then indeed, the version of ipw2100 driver I'm testing here
doesn't support that. Still feels a bit backwards to get correct
result as a normal user, incorrect as root :)

Comment 4 Bill Nottingham 2004-08-27 22:42:01 UTC
Please try the test RPMS at:

http://people.redhat.com/notting/kudzu/

Comment 5 jens.koerber 2004-09-18 13:16:29 UTC
works for me with kudzu-1.1.36.3

class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: hisax
desc: "AVM Audiovisuelles|A1 ISDN [Fritz]"
vendorId: 1244
deviceId: 0a00
subVendorId: 1244
subDeviceId: 0a00
pciType: 1
pcibus:  0
pcidev:  d
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: 8139too
desc: "Realtek|RTL-8139/8139C/8139C+"
network.hwaddr: 00:30:84:3F:D1:B4
vendorId: 10ec
deviceId: 8139
subVendorId: 1259
subDeviceId: 2503
pciType: 1
pcibus:  0
pcidev:  e
pcifn:  0ppp_synctty             6304   0 (unused)



-------------------------------------------
ppp_async               7968   1
snd-pcm-oss            43624   0 (autoclean)
binfmt_misc             7040   1
snd-mixer-oss          14360   0 (autoclean) [snd-pcm-oss]
r128                   88256   1
agpgart                17424   3
snd-seq-oss            28800   0 (unused)
fcpci                 588992   3
capi                   20480   6
capifs                  4812   1 [capi]
kernelcapi             32416   4 [fcpci capi]
capiutil               24640   0 [kernelcapi]
.
.
.
8139too                16328   1
mii                     3848   0 [8139too]





Comment 6 Bill Nottingham 2004-09-20 05:26:50 UTC
Marking as fixed in the update.


Note You need to log in before you can comment on or make changes to this bug.