Bug 111647 (TBe1684e00) - redhat-control-network:344:hydrateProfiles:AttributeError: 'NoneType' object has no attribute 'remove_menu'
Summary: redhat-control-network:344:hydrateProfiles:AttributeError: 'NoneType' object ...
Status: CLOSED RAWHIDE
Alias: TBe1684e00
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 122619 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-07 21:55 UTC by Gregory Harris
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 13:55:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception data (2.28 KB, text/plain)
2003-12-07 21:56 UTC, Gregory Harris
no flags Details

Description Gregory Harris 2003-12-07 21:55:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
An unhandled exception occurs when trying to close redhat-config-network.

Version-Release number of selected component (if applicable):
1.3.10

How reproducible:
Sometimes

Steps to Reproduce:
1.  open redhat-config-network
2.  try to configure an interface
3.  enter root password
3.  press the upper-righthand x to close the root-accessed dialog
4.  press the upper-righthand x to close the non-root accessd dialog
    

Actual Results:  exception dialog occured.

Expected Results:  no exeception dialog should occur.

Additional info:

Comment 1 Gregory Harris 2003-12-07 21:56:02 UTC
Created attachment 96390 [details]
exception data

Comment 2 Bruce Sinclair 2004-02-05 00:28:34 UTC
Happened when I upgraded from 14k4 modem to 56 k (both dynalink). 
Used to work quickly and reliably, then almost froze and I shut it 
down. Then tried Kppp. Have since found that the delay is apparently 
built into the modem - If I wait, Kppp works most times. Might be a 
timing problem ?
Can use Kppp to connect as a work around, but that requires root 
priviledges.

Error report below.

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/bin/redhat-control-
network:382:hydrate:AttributeError: 'NoneType' object has no 
attribute 'clear'
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 183, in 
on_activateButton_clicked
    self.update_dialog()
  File "/usr/bin/redhat-control-network", line 503, in update_dialog
    self.hydrate()
  File "/usr/bin/redhat-control-network", line 382, in hydrate
    clist.clear()
AttributeError: 'NoneType' object has no attribute 'clear'

Local variables in innermost frame:
clist: None
plist: None
self: <__main__.mainDialog instance at 0x85189bc>


Comment 3 Harald Hoyer 2004-05-06 12:45:46 UTC
*** Bug 122619 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.