Bug 111662 - mozilla crashes on startup when built with gcc 3.3
mozilla crashes on startup when built with gcc 3.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-08 05:04 EST by Alex Kiernan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 14:52:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to spec file to apply nsCOMPtr patch (620 bytes, patch)
2003-12-08 05:05 EST, Alex Kiernan
no flags Details | Diff
Existing bugzilla.mozilla.org patch modified for 1.4.1-18 (1.05 KB, patch)
2003-12-08 05:06 EST, Alex Kiernan
no flags Details | Diff

  None (edit)
Description Alex Kiernan 2003-12-08 05:04:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4.1)
Gecko/20031203 Epiphany/1.0.4

Description of problem:
Mozilla 1.4.1 is miscompiled by gcc 3.3 due to an aliasing problem in
the codebase (http://bugzilla.mozilla.org/show_bug.cgi?id=212082).



Version-Release number of selected component (if applicable):
mozilla-1.4.1-18

How reproducible:
Always

Steps to Reproduce:
Run mozilla on a ppc box
    

Additional info:
Comment 1 Alex Kiernan 2003-12-08 05:05:06 EST
Created attachment 96393 [details]
Patch to spec file to apply nsCOMPtr patch
Comment 2 Alex Kiernan 2003-12-08 05:06:39 EST
Created attachment 96394 [details]
Existing bugzilla.mozilla.org patch modified for 1.4.1-18
Comment 3 Paul Nasrat 2003-12-17 09:12:12 EST
These patches are fix correctly the bug worked around described here

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=109691

Comment 4 Christopher Blizzard 2004-01-20 14:52:19 EST
Mozilla 1.6 is now in the rawhide tree and that includes these fixes.
 Marking RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.