Bug 111694 - /etc/inputrc has wrong codes for Ctrl+Left/Right (with fix!)
Summary: /etc/inputrc has wrong codes for Ctrl+Left/Right (with fix!)
Status: CLOSED DUPLICATE of bug 80860
Alias: None
Product: Fedora
Classification: Fedora
Component: setup   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-08 20:56 UTC by Reuben Thomas
Modified: 2014-03-17 02:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Reuben Thomas 2003-12-08 20:56:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.23  [en]

Description of problem:
/etc/inputrc claims to bind Ctrl+Left/Right to backward/forward-word 
in readline.

In fact, it doesn't work (since RH9, I think). Instead of the lines

"\e[5C": forward-word
"\e[5D": backward-word

in /etc/inputrc, the following is required:

"\e[1;5C": forward-word
"\e[1;5D": backward-word

I haven't a clue why, I assume the escape sequences are different in 
the current version of xterm (at least as supplied with FC1).

I'm using the supplied bash in the supplied xterm to get these 
results.

Version-Release number of selected component (if applicable):
2.5.27-1.1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Bill Nottingham 2004-09-23 05:06:16 UTC
Hm, this works in gnome-terminal, but not xterm. And adding the
suggested fix works in xterm, but not gnome-terminal.

Comment 2 Bill Nottingham 2004-09-23 05:33:12 UTC

*** This bug has been marked as a duplicate of 80860 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.