Bug 111708 - Segfault on long lines
Segfault on long lines
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-08 20:57 EST by ratness
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 07:40:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of a sigfaulting test (7.63 KB, text/plain)
2003-12-15 09:23 EST, Matteo Corti
no flags Details

  None (edit)
Description ratness 2003-12-08 20:57:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Long lines are causing 'less' to break in odd manners.

Version-Release number of selected component (if applicable):
less-378-11.1

How reproducible:
Always

Steps to Reproduce:
Works: perl -e 'print "a" x 1066;' | less

Segfaults: perl -e 'print "a" x 1067;' | less

Explodes: perl -e 'print "a" x 1089;' | less
less: multi.c:1232: buffering_multi: Assertion `mp->intindex == 0' 
failed.
Aborted

Additional info:
Comment 1 Matteo Corti 2003-12-15 09:23:09 EST
I can reproduce the bug but only as a non-root user.
As root everything works fine.
Comment 2 Matteo Corti 2003-12-15 09:23:48 EST
Created attachment 96537 [details]
strace output of a sigfaulting test
Comment 3 Karsten Hopp 2004-01-14 07:40:49 EST
works for me as root and non-root. Which locale are you using ? 
Comment 4 ratness 2004-01-14 10:40:59 EST
I'm using en_US; I see it as both root and mortal users.

Note You need to log in before you can comment on or make changes to this bug.