Bug 1117128 - Missing pictures in impress (still)
Summary: Missing pictures in impress (still)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 06:08 UTC by Matt Hirsch
Modified: 2014-07-26 16:01 UTC (History)
7 users (show)

Fixed In Version: libreoffice-4.2.5.2-10.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 07:53:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 46447 None None None Never
FreeDesktop.org 81630 None None None Never

Description Matt Hirsch 2014-07-08 06:08:21 UTC
Description of problem:

As requested in bug 1084822, I'm opening a new bug, as I continue to experience the problem described there, and described in longstanding bug report https://bugs.freedesktop.org/show_bug.cgi?id=46447

Upon saving a presentation in LibreOffice Impress and reopening it, some images disappear from the presentation.

Version-Release number of selected component (if applicable):
libreoffice-4.2.5.2-1.fc20.x86_64

How reproducible:
Frequently, especially with a large presentation.

Steps to Reproduce:
1. Open a presentation
2. Make a change, such as inserting an image into an existing slide, or pasting a new slide in from a different presentation.
3. Save the presentation, and close Impress
4. Open the presentation again

Actual results:
Sometimes, some images in "untouched" slides will be replaced with red text saying something like "Picture 3".

Expected results:
All images are present.

Additional info:
This seems to be a very longstanding bug. I have personally encountered this for quite awhile, and it also seems to be open in the libreoffice bug tracker for over two years.

https://bugs.freedesktop.org/show_bug.cgi?id=46447

Comment 1 Matt Hirsch 2014-07-10 07:45:33 UTC
After some additional experimentation (and as noted in the freedesktop bug) this seems related to autosave. After disabling autosave in libreoffice, I have not had this problem.

Comment 2 Caolan McNamara 2014-07-14 12:22:11 UTC
More of a catch-all "pictures go missing" bug because there has been a series of them rather than a single persistent one. I had rather hoped that the last round of fixes was the last.

Anyway, is your one reproducible ? odp file format I presume ? Was it the default auto-save timeout or a custom one ? Does it happen just with one presentation or across a set of presentations ?

Comment 3 Matt Hirsch 2014-07-17 17:57:57 UTC
Yes it was ODP. I was using the default auto-save timeout. It occurs with great regularity in that almost every time an auto-save occurs images will go missing, but is not repeatable in the sense that different images will disappear on different saves. I can try to create an example presentation this weekend.

Comment 4 David Tardon 2014-07-24 07:53:31 UTC
I pushed a patch that--I hope--fixes this.

Comment 5 Fedora Update System 2014-07-24 12:40:13 UTC
libreoffice-4.2.5.2-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.5.2-10.fc20

Comment 6 Fedora Update System 2014-07-26 16:01:10 UTC
libreoffice-4.2.5.2-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.